Nuki Bridge Beta - LAN-only mode

With the new Beta I have problems to but the Nuki bridge in “private mode”. If I block the internet-access of the bridge the api won’t work properly. Bridge is configured and working properly with OpenHAB but if I cut the line it’s dead.

There is a topic on LAN-only mode. But I can’t connect to the Wifi without internet connectivity.
Suggestions? Am I doing something wrong?
Or is this really an issue because of the Beta firmware? Under normal conditions this should work

1 Like

I have the same issue just now. Moved the bridge to a separate VLAN for IoT devices and I see the bridge connecting but it’s unresponsive and the Nuki app keeps saying “No Bridge in maintenance mode found” whilst the light is blinking.

Kinda defeats the purpose of having a LAN-only mode (which was advertised).

Also I have no way of connecting to the bridge again to change the WiFi network so I’m currently stuck with a bricked device…

There still can be issue with offline usage, but what you describe sound like different problem to me:
Have you ever been able to connect to the Bridge? iOS or Android device?

I have taken the plunge and tried again with version 2.2.9 on the bridge. Without internet access it would simply not allow connections to the local API. I could however connect with bluetooth which is a big improvement.

The brige settings looked like this, see the weird IP of (looks like the bridge didn’t get an IP, whilst checking my DHCP leases it did).

After allowing traffic on port 443 to sse[1-9] (untrusted SSL cert btw) and rebooting the bridge it would show connected to the server (yay) and the API became responvie again (and showing the actual LAN IP).

Seems like it’s still a minor bug that the local API doesn’t become available if there’s no internet connection.

Are there any news about this bug?
With Firmware 2.2.13 there is no connection possible to the API, when no internet connection is available.

Do you have the same problem as described above - with IP address not recognized correctly - or something else?

It is similar to the problem above.
In the app the IP has been shown as, but the connection (ping to the bridge) is possible. I am using DHCP with static lease.
If there is no internet connection the HTTP API is not working correctly. E.g. there is no response if I will request the lock status.

@Fritz: Exactly the same here

Hi Stephan, no idea in this case or is it a known problem with no workaround?

Sorry for missing out on your answer:
There is a known bug that IP can be lost if a restart occurs while the brige is offline. So in theory a workaround with setting it up online and then remove access would work, but only till the next restart. (That’s why I asked because your description sounded like even that would not work.)

This should also be addressed in the next Bridge FW Beta (no release date set yet).

Thanks for your answer.
But I think, that is not the problem in my case. I can ping the bridge, but the API does not answer. The IP looks assigned correct. It seems the bridge needs an internet connection for the API to work.
May be, this is another problem.

1 Like

The same in the SW Android Bridge.

Without Internet Access /lockState and /lockAction not working.

Ping the device is no problem. /list or /info is working

Any news about the FW Beta yet?

The problem is still present in firmware 2.4.21 and it doesn’t only occur when the bridge is offline during the restart but also if the internet is unreachable later on.

I admit, I’m a bit worried that the problem has been present for 7 months now and that my support request has not been answered yet. I’m not confident that the problem will be solved in the remaining days I have to send the product back.


LAN only should work as long as the bridge can ping the default gateway. If this is not the issue on your side please send us a Bridge-log.

ok, will test later … i only blocked outgoing WAN traffic for the device.
/list and /info Request were working … so i think ping is possible

how can i enable logging on the android app?

The default gateway is pingable. I verified the packets going in and out.

I sent the logs to hoping for a quick fix.


1 Like