Nuki Bridge 3 connects to the farthest, not closest, AP?!

Hi all,

I’d appreciate any insight into this weird issue I’m seeing.

I have a Nuki 3 lock and a Bridge. The Bridge is obviously connected to my WiFi network. There are several Ubiquiti APs around the house and yard.
The bridge has an AP just above it - say, 4 meters away, clear straight line of sight. But I noticed that it connects to a different AP, one that is in the yard of all places, and obviously gets poor connection quality. No matter what I do, it will not connect to the AP that’s near. Tried: (a) many reboots; (b) shutting off the yard AP (it would then connect to another, front yard AP, and then when the latter is shut off, does not connect at all); (c) “locking” this client to the closest AP using the Ubiquiti management.
No action makes it connect to the AP that’s right nearby. When “locked”, it would just not connect.

Help?! I’m at loss as to what could be causing this.

You can force the AP in the Unifi Controller.

Thanks for responding. Yes, I tried that - see (c) in the original post. Does not work - the bridge just doesn’t connect to the “close” AP once I lock it to that one.

Create a seperate WiFi-network (i.e. different SSID) and publish that only on the AP nearby.