Nuki app crash on galaxy watch 4 wear OS 3

Hello, I switches from a ticwatch PRO 3 running wear OS to the new galaxy WATCH

The nuki Opener application does not work anymore… any time you want to swipe in order to Access the unlock screen, the program crashes.
I’m using the latest version of the bêta program.

Do you have an idea?



I’ve the same issue with mine. It works for the Opener, but for the Smart Lock, It crashes also everytime trying to enter the unlock options (swipe to right Page).

1 Like

Same on ticwatch pro 2, since a while now!?

I’ve the same issue, never worked for me on Watch 4 and stable version

Thanks for the report. This issue will be fixed in the upcoming release.

1 Like

thanks, because have the Same Problem with Galaxy Watch 4

Problem is solved with last release.
Thanks for support

1 Like

Hi! I’m a step behind you. I just can’t find Nuki app on Galaxy Store for my Samsung Galaxy Gear Sport smartwatch… any tips?

Hi! Have you found it in the meantime? If not, I think you have to search for watch apps specifically to get the app on the watch! Try to search for Watch Nuki!

You can’t find it in the store with wear os 3…
Whatever you are searching for

Have you tried to just Sideload and Install it?