Nuki 4 Pro and HomeKit - Matter issues

Just installed 3 units Nuki 4 pro, still on FW 4.1.8

They are few meters away from variuos TV, HomePod mini, HomePod.
WiFi coverage is provided by Ubiquiti gear.

The 3 units are all behaving differently:

Unit #1 - connected using Matter, works via Nuki app, works via Home, Matter access OK
Unit #2 - connected using Matter, works via Nuki app, appears in Home but doesn’t work
Unit #3 - connected using WiFi, works via Nuki app, unable to add it to Home, unable to access via Matter, HomeKit configuration process hangs on “Connecting”

Tried different strategies, resetting, removing, the most concerning is Unit #3 that seems slow responding during configuration process. I have added all to beta program, waiting for them to get updated. Also swapped units position to see if a particular location was affecting BLE or WiFi or Threads performance, but the one that works, works everywhere while the buggy ones are still behaving the same way.

I have now changed Energy Saving to “medium” to see if it helps.

As environment is the same for all 3 units, I am curious to understand if there’s any testing I can perform align them all.

Via Nuki IOS App all of them are working. Will update this post if I find anything with further testing.

Thank you in advance for your suggestions!

Can you say what the range from the Nuki to the border router is? This range could be a key to the different behaviour… Can you look what is the actual border router active (ATV or Homepod)?

In my posts you can see, that an active ATV has less range than an ATV in Standby… But with 17.4 the Nuki is unailable in the UI but it works… But Matter to seems to be quite instable at my device at the moment with 4.1.8…

One lock is 4 meters in LOS from a HomePod and the other 2 are also 4 meters in LOS from an HomePod Mini.

All 3 locks are now subscribed to Beta program and I have received the notification to upgrade them all. However I have not updated yet. Yesterday I have spent some time familiarizing with configuration, did some test and identified a working procedure to use Nuki 4 Pro with  Home / Matter / HomeKit.

Essentially it doesn’t matter if they have been previously configured and not working as expected, resetting and also power-cycling them removing the battery has no effect (at least in my experience).

If you find yourself in a situation in which they are partially responding (like my case - see initial post) just disable WiFi and Matter using the Nuki iOS App, delete locks from  Home App, and re-add them to  Home.

This worked for me, they have been added flawlessly and working well so far (12 hours so far). I would say that if you enable WiFi in the first step of the first configuration using Nuki iOS App they become reluctant to switch to / interact with Matter / Threads network, and also Bluetooth seems less effective. A hiccup in config flaw maybe.

These are just user considerations, please take them as they are, if you try doing this procedure please post a feedback here.

This has been done on FW 4.1.8 - Power Saving Mode automatic.

hi, I seem to have the same problem - cannot add my Nuki 4 lock to HomeKit.
My setup consists of:

  • apple tv 4k 2nd gen (with matter support, I already have a few matter devices in my home app),
  • Nuki bridge
  • Nuki smart lock 4
  • Nuki opener
    The problem is I can’t seem to be able to add Nuki do HomeKit. Pressing “matter” in smart home integration in Nuki app gives mixed results: sometimes it lets me through to the next screen, sometimes it errors out on “cannot download information”. Home app sees the lock but it either hangs on connection while adding it to HomeKit or returns error “no border router detected”.
    This is my first Nuki product, and quite frankly it’s kind of disappointing.