Nuki 4.2.6 Home Assistant no unlatch

Hi Everyone,

cause of the ongoing problems with MQTT over Wifi i tried Matter.
I was able to connect the Nuki 4 pro with Firmware 4.2.6 to Home Assitant via my Apple Thread network (I didnt connect it to Apple Homekit, only to Home Assistant) - unfortunately it dont show the “unlatch” action.

In Home Assistant the Lock shows with Firmware 4.1.0 in Nuki App with 4.2.6… Is there anything wrong?

nobody here with a Smart Lock 4.0 connected to Home Assistant via Matter?

Any help from @NUKI ?

“ This new feature is for now only available in case Home Assistant is used as a Matter Hub.”

I think, you will have to wait until Apple updates their hubs.

Alternatively you can use mqtt with thread, unlatch works there.

I know, I don’t use apple HomeKit as matter hub, the Nuki is directly connected to home assistant.

I only use the apple thread network, but the way the device is connected via thread shouldn’t matter in my opinion - would be great if anybody from @NUKI could help here.

Yeah I tried this, it works for now

Correct, I do not know why unlatch depends on thread, since it is a matter 1.2 feature.