Nuki 3.0 Pro Opens door by Unlocking

Hello and good Morning.

i have the issue, that when my Nuki 3 Pro when I “unlock” the Door via MQTT or via the App the Door get’s opend immediately. This is a new behavior, because in the past the Door gets only unlocked and not opend.
The door has an Bar outside.

This is from my Point of view an Issue.
Is ther an possibility to change the behavior back to the old one?

Looks like a position loss of the Smart Lock. Try to completely lock it with your hand or take out the batteries and reinsert them (which triggers a position run). If this does not help, recalibrate it.

I have done that all, and still pulls the Latch until the Door is open.
Also i have tried the Hardway and Factory Reset the Lock but still the Issue.

Well, i guess the problem is more simple:

If you execute /lock or /unlock you execute the “simple lock actions”. Simple /unlock for a door with knob at the outside translates into the unlatch command.

You have to call /LockAction with the proper lock action behind.

Check the spec for details: MQTT API Specification v1.4

That’s strange because before the Unlock was working like a charm via MQTT or App. Even with the Timeschedule via App the door opens.
Could this be maybe really an Software issue?

This was not the case one or two month before.

I’m using the following Service call from Home Assistant.

When the Smart Locks activity log says “Tür geöffnet” / “Door opened” an unlatch command has been executed. So this is no bug on the Smart Lock side, it just did what it was told to do.

Yes I understand. But from the wording: Unlock / Aufsperren is something different then Door Open / Tür öffnen or do I understand the wording different?

The Door open is the Result of the Unlock. Because the Lock does an Unlatch after the Unlock command was send. Even via the App the Unlock does an Unlatch.

My issue is that the Unlocking has worked since the Installation of my Lock in 2022 without an issue.
But since round-a-bound a month the Lock is not working like it was before.

I will make an Video of both, Mobile and the Lock what happens when i do an unlock and post that here, for clarification

Same problem here, if I do an Unlock door from the app, till yesterday it did a simply unlock, since today is performing an unlatch/open.
Also the button on the Nuki is configured to do a simple unlock with one press and an open/unlatch with two presses, but now it does not work anymore.

You can see from the image: at 14:01 I simply unlocked it but the door was unlatched

But the image says “sbloccata” (unlocked), but it was actually opened

That’s a different problem than mentioned above. If you see “unlock” in the App but the door gets “unlatched”, it lost its calibration. You need to recalibrate it. Taking out the batteries and reinserting them might also work as it triggers a position run, which also repositions the Smart Lock. Also fully locking it by hand/key should fix the lost position.

I did both of them but it did not help

I think there is an issue with MQTT Autodiscovery in Home Assistant. If I run this script instead of calling unlock, if it does not unlatch indeed:

      - service: mqtt.publish
          topic: "nuki/XXXXXXX/lockAction"
          payload: "1"