Nuki 3.0 PRO offline?


I have a 3.0 PRO. All is working fine in my house but when I am out I can not control the Nuki from the app (iOS) because it says is offline. Inside my house I can check the connection status and seems that there is no connection between nuki and the server.

The thing is that out of home I can control the Nuki using the web without any problem, so there is internet connection in the Nuki.

Any help with the Nuki app?


Delete the Smart Lock from the App and add it again. If it still does not work, please contact our support via the Nuki App (Menu > Help > Contact Customer Support) for more detailed help.

This forum is focused on developer related issues.

Same problem here… only found out that it is not reachable when not on the LAN with my phone
When I was no longer onsite :rage:.
Will have to go back to our holiday home to fix it.

Also did not get the connection with a keypad working correctly… issue not yet solved.

If Nuki Web is activated and working, you can remove the Smart Lock from the App and send yourself an invite through Nuki Web. No need for a local presence.

Also NukiWeb shows an offline status

Hi all,

exactly the same issue…

I can only lock/unlock when i’m in my home.
on the app i don’t see connection with the server and on Nuki web it’s appear offline too…

HI again,
i solved my issue, my router have 2.4GHZ and 5GHZ WIFI, my router broadcast the same SSID for 2.4 and 5ghz.
I changed the setting for the WIFI on my router to have one SSID for 2.4 and another for 5ghz, connect the smartlock to the 2.4ghz SSID and now all is working fine.
Please test it and tell me.


I fixed my problem removing the Nuki from the app and then adding it again. The config is not lost in the process.

Hi, since my last post…it doesn’t work today…very boring.
My door sensor doesn’t works too…

And now i see a new issue, when you manualy unlock your door, the status doesn’t changes on the app.

to summerize :

  • Nuki 3.0 Pro always offline (except in bluetooth)
  • Sensor door, calibration ok, but firmware upgrade succesfull but still apear in the previous firmware and ask me to upgrade it… the door appears always closed…

A lot of bug for all nuki products :frowning:

Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) as this is an individual problem and might require sharing logs and other sensitive data.

This is a developer forum and focused on developer issues.


ok thanks i contacted the support.


It is not an individual problem! I have this problem since October 2021 too. I contacted athe customer service and they don’t answer for weeks! And even if they do answer, they pretty much only write generalities, they don’t solve the problem. I’ve been with the lock for 3 months now, so that it’s only online when I’m inside the apartment. As soon as I go further, it goes offline.
Unusable, just like the customer service is unusable!!!