Not able to pair with Android Wear (V2)

Hi there,

I had the same problem (Fossil gen 5 Carlyle), Nuki Lock 2.0 (software version 2.6.6).
The reason was, that on the lock button options for “bluetooth pairing” were not enabled. After enabling bluetooth pairing via button I could pair my smartwatch.

Note, that the smart watch app does not give an error message in that case, it just searches for the lock.

Hope that helps.

After countless attempts to couple my Huawei Watch2 with the NUKI, I eventually made it. I think the 4 sheet metal contacts for keystroke recognition on the NUKI are just total crap and absolutely cheap.

If I am sitting with my watch in front of the lock and I have my smartphone with me, I can open and close the lock with the Smartwatch.

But if I only sit with the watch in front of the lock, I get the message that no Smartlock is available. Only when I bring the mobile phone within range again, the watch will have contact to the lock again.

Obviously the connection is established as follows NUKI -> Smartphone -> Smartwatch.

That’s pretty pointless, if I leave the house without my mobile phone but with the watch, I can’t get in because even if I stand directly in front of the door, there is no connection to the watch because the mobile phone inside is out of range of the NUKI.

Android app version is 2.6.5

I cannot even use the Nuki app on my Wear OS device anymore (Skagen Falster 3): I had to reset my watch, so I removed the user “Falster 3” in the Nuki app on my smartphone, then reinstalled the app but all the app on my watch now does is show “Loading devices” (“Apparaten laden”, in Dutch) and then a black screen. I have absolutely no idea why this is happening …

Please send a log-file with a short description of the problem and the exact time when it occured to our support team at contact@nuki.io, so they can check the details of what happend.

Log file sent - thanks for the follow-up!

I am experiencing the same issue.

I re-installed the nuki app on my Fossil Carlyle watch after the app stopped connecting to the door lock via bluetooth and I could not re-pair the device. My wifes apple watch and our phones, an Android and iPhone, still worked fine and were able to pair with the lock.
After re-installing the nuki app on my Android wear device it is now useless.
Three scenarios can occur when launching the Wear OS app.

  1. Just get a blank screen at launch
  2. Gives the message “Loading devices…” and then gives the blank screen after a couple seconds
  3. Give the message “No Phone Connected”

I hope there is a solution for this soon as it was working fantastically well when I first set it up.

Any updates would be much appreciated.
Thank you

A new Android App Beta is available which addresses the issue:

https://developer.nuki.io/t/app-update-nuki-android-app-2-6-8-beta/5882/2

If feedback for it is good we will roll it out to all users soon.

Thank you Stephan,

The beta version has resolved the nuki wear app “Loading devices…” issue and I’m now able to use the app again.
I am still not able to pair the nuki wear app with the smart lock so that it can function without the need for my phone to be around.
I have emailed the logs through if that helps.

Thanks again

Leider erlebe ich die Probleme mit der Smartwatch - Steuerung (mittlerweile verschiedene Modelle mit WearOS) nun schon seit 3 Jahren. Das Schloss läßt sich trotz erfolgreichem Pairing nicht bedienen, das Schloss wird von der Uhr nicht gefunden, der Bildschirm der Uhr bleibt schwarz usw. Vielleicht sollte Nuki endlich so ehrlich sein und offen zugeben, dass eine verlässliche Steuerung von Nuki 2.0 mit einer Smartwatch nicht funktioniert. Das würde vielen Besitzern einer Watch Nerven und stundenlange Fehlersuche ersparen.

Hello
Not able to pair with a ticwatch pro 3…

Always indicating : searching for a smartlock… i can see the smartlock in the list of available BT devices and I can pair with it independently of the nuki app. I’musing the latest beta app and latest firmware on the smartlock…

Creo que lo he conseguido, apagar bluetooth del smartphone, conectar mediante bluetooth y Nuki fuera de la app de Nuki y luego acoplar con la app de Nuki. Ticwatch Pro 4g

Hi! turn off Bluetooth on the smartphone, connect bluetooth to Nuki without app, pair Nuki to smartwach with the app (Press Nuki for five seconds …) in the Nuki app, the option to pair bluetooth devices must be enabled. Sorry for the translation.

Same here. I’m able to pair the watch with the lock, it appears in the user list on the phone app, but I can’t actually lock or unlock without the phone. I went through three different watches trying to get it to work.

Now suddenly the claim from Nuki Support is that this is not even expected to work:

Hello Jens!

Thanks for your request!

It is not possible to connect your watch directly to the Smart Lock via Bluetooth.
The Command of the Watch always needs to “run over” the Smart Phone. This then sends the command to the Smart Lock.
So it is possible to leave the Smart Phone directly next to your door, then you can unlock from the outside.

Best regards
Julia

and after I complained again, this:

We are really sorry, but at the moment it is not possible for Android devices to operate with the Smart Lock without the Smart Phone connected.

We are working on a solution, but there is no exact timeframe, until when all Smart Watches can access directly to the Smart Lock.

It would be really nice if Nuki could stop advertising features that apparently they know don’t work, wasting people’s time and money.

Hello Jens,

thanks for reaching out. In general it is possible to directly perform lock actions with the Wear OS app. Which watch and Wear OS are you using? Happy to help!

I am sorry that you got a misleading answer from your support. I’m in touch with our support to clarify you request.

Hi Stefan, I have so far had a TicWatch Pro, a Fossil Carlyle Gen 5, and currently an Oppo Watch (41mm). Luckily I was able to return the first two. On all three the WearOS app showed successful pairing with the lock, and the corresponding user appeared in the Android app. But I have never been able to actually do a lock or unlock operation purely from the watch.

Hi, Stefan. What are you saying " In general it is possible to directly perform lock actions with the Wear OS app. " ?
NUKI claim for 2 years ago that we can use the Android Wear/Wear OS watches WITHOUT SMARTPHONE, in order to lock/unlock Nuki Smart Lock 2.0.
From the same side, Chat Nuki specialists say that at this moment is not possible ( 2 chat sessions in this days, same answer - is not possible to lock/unlock with Android wear /Wear OS watch, without smartphone).
Like Jens, I think also that : “It would be really nice if Nuki could stop advertising features that they know don’t work, wasting people’s time and money.”
If you know that feature is not working, what is the reason to keep in Android/WearOs Nuki app for watch, the 3rd page with “Direct access” pairing menu? I waste many days to understand what I’m doing wrong !
I even succesfully pair watch with NukiSL2.0, I see the NUKI SL2.0 in bluetooth devices as active device, but I can not lock/unlock the Nuki Smart Lock ! “Smart Lock is not reachable” is the message received, even the bluetooth connection between watch and NukiSL2.0 is ACTIVE.

Stefan, please read this Nuki post from 2019 :

…We want to give you an early Easter present with the latest update of your Nuki iOS app. Because what already works with Android Wear is now also possible with the Apple Watch: directly controlling your Nuki Smart Lock with your Apple Watch…

…already works with Android Wear? In 2019 ? That feature NEVER WORKS IN THE PAST !

Just want to say that unlocking and locking now perfectly works with my Ticwatch Pro 3 using Android Wear. Sometimes it can be a little slow to recognize the lock but not longer than 30 seconds.

One extra data point.
Was failing to connect my new wear 2 watch with my lock.
Found this post, deleted the user for my previous wear 1 watch, and it worked immediately.
This is clearly a bug. At least some guidance in the wear app to remove other instances might help users?

Please update your apps to the latest version: App Update: Nuki Android App 2.7.7, we fixed several issues around the watch app.