Missing text on buttons in Nuki Web - API page

Hello,

I just notice that texts are missing on action buttons in the Nuki Web API page. Just in case you miss it!

Also, how to unlock the Advanced API tab and how can I rotate my API keys?

Kind regards,
Anthony

Hi Anthony!

I could not reproduce the missing text on the button!? Did you already try to force refresh the page and/or change the language back and forth? (What browser are you using)
The Advanced API request and API key management are on the page you screenshotet, but we need to make it work for you first to be usable.

Hi Stephan,

Reopening this.
I’m still facing the issue even after reaching out the support multiple time for this specific issue.

I try everything listed below :

  • Force refresh the page (it sends me to the login page, and still buggy after login)
  • Can’t change the language, so can’t try this (see screenshot)
  • Try with Firefox both private/non private, Chrome, Safari, Tor
  • Try to force change the language at login
  • Inspect the code to find if there’s the text (and there’s no text)

I also can’t access to the advanced API features.

Could you help me on this? I’d faced this problem for a while now, and it starts to be a fence for our development.

Thanks for your help!

So this behaviour for you exists on all common browsers (which version and which OS?)

This is very strange as we have no comparable case and could still not reproduce it. Could you try out your account on a different device/in a different network to further track down the issue?

EDIT:

This sould also only happen if you NOT choose the “keep me loggen in” functionality.

Unfortunately, it’s still here. I manage, don’t know how, to get work the locale change menu one time, but it don’t last.
I tested :

  • On Firefox (private session) 86.0 on my 2017 MacBookPro macOS 10.14.6
  • On Firefox Focus on my Galaxy S20 Android 11
  • Two different networks
  • Flush the cache

Ok, got it for the keep me logged in!

Would you want me to do another test or send you some logs?
Thanks for your help

Ok, I find something interesting for you @Stephan!

In the JS console I have an endless loop on the error ERROR TypeError: e.redirectUris is undefined when I’m on the API page
It made my tab crash when I opened the JS console.
Is this e.redirectUris something about my webhooks created by API?

Any news here?

Sorry, I just saw your last feedback now, as I have been out of office. Will check if this helps us reproduce the issue.

It’s just a wild guess, but could it be that you already tried to create one API Token which accidentally had a Name with a series of characters which breaks JS-code when loading the page?

If so, and you stored this key somewhere, you cold try to read the existing API Keys via the WebAPI do find a hint to the problem there.

You mean, that the key could mess up JS because of the chars in it interpreted by the JS interpreter? It would be a real threat as it will show up a vulnerability for JS code injection. I guess (and hope) it’s something more trivial such as a bad redirectURL params that raise an error because it’s missing or the URL isn’t formatted the way they need it

Perhaps it isn’t JS. But just anything else that breaks. A malformed key name would be an explanation why it only occurs in your account but independent of the device. As I said, just a wild guess.