Lock 'n' go via MQTT does not fire trigger in home assistant

I use a nuki 3.0 pro that is via MQTT connected to home assistant.

I tried to use a trigger for lock and go but it did not fire.

I tried to lock the door via app and via push button on the device itself.

Locking and unlocking the door via home assistant works fine.

I did some research. There is no event for “lock and go” on the event bus.

Hi Thomas, you have to read this:

Add in your configuration.yaml:

    - unique_id: 12121212121a
      name: "Nuki Lock Action"
      state_topic: "nuki/XXXXXXXX/lockActionEvent"

An example of automation:

alias: Lock Action Event
description: Lock Action Event Automation
  - platform: state
    entity_id: sensor.nuki_lock_action
condition: []
  - choose:
      - conditions:
          - condition: template
            value_template: >-
              {{ trigger.to_state.state.split(',')[0] == '4' and
              is_state('switch.alarm_status', 'off') }}
          - service: switch.turn_on
            entity_id: switch.alarm
1 Like