Local MQTT connection fails there is no connectivity to Nuki Cloud Servers


I have a Nuki 3.0 Pro, it connects to a MQTT Server on my local LAN, which is talking to my local Home Assistant.

I noticed that Nuki is “health checking” the Wifi Connection by connecting to the Nuki Cloud. If the connection to the Nuki Cloud fails, Nuki 3.0 Pro will disconnect from the Wifi.

Of course when Nuki disconnects from the Wifi, MQTT also stops working and my local Home Assistant cannot communicate with Nuki anymore.

I’m pretty sure the other local integrations like Homenet or the Bridge HTTP-API suffer from the same issue, when Nuki rejects or disconnects the Wifi due to lack of Cloud connectivity.

I would like to do reliable local controlling with MQTT/Homenet/HTTP-API, but:

  • not depend on the spotty internet connection of my place
  • not depend on cloud servers by Nuki (I would prefer Nuki to not connect to the Cloud at all, I don’t need or want any of the Cloud features)

I think this would be an important improvement.

This was considered a bug in the Bridge:



If you want a new feature, please create a feature request and start collecting votes for it. Before you do that please check if there is already an existing one.

In 2020 you considered this a bug when it was happening on the Nuki Bridge as per the thread linked above.

I understand you have a lot of roadmap items, I just think this is something a little more important than a specific, exotic and optional feature.


I filed the feature request here:


I have just voted for your feature request. Can’t even imagine this should be a feature. Imho this is a bug. Otherwise the whole MQTT seems useless, because there is still dependency on the cloud. For me a reason to go for another product if it stays like this.


Is it easy to ‘spoof’ this behaviour or is it a complex call which is made to a random cloud server?

Those are HTTPS requests to sse[0-9]-smartlock.nuki.io, all in the IONOS Cloud.

And ICMP unreachable in response to the SYN will lead to a timeout so it takes a few retries before Nuki ultimately times out and disconnects from the Wifi.

When a TCP RST is returned, Nuki disconnects from the Wifi within a few milliseconds.

I did not try to respond with my own HTTPS Server. I’m not really interested in workarounds on my site, because I consider that this is something that is either a core design principle, or the product is not what I’m looking for at all.

I have returned the 3.0 Pro at this point and will use a normal 3.0 with the ESP32 integration, which as far as I can tell is really well made.

Then I have a solution that actually fulfills my requirements without Cloud enforcement and I have about 100€ left to spend on nice things.

1 Like

Hmm… I can get my hands on a N3P for 189€ new. So that’s including the battery pack.

I totally agree that this should be core functionality. It should be able to ping the local gateway and that’s it (or a check of MQTT is connected).

Maybe I buy the N3P and still use it with the esp option, but this is a really bad design choice (bug). Food to think about.

1 Like

Please fix this, i’m using an lte connection which is not verry stable. Nuki is constantly disconnecting from mqtt server.


I voted for your request. I’m actually surprised it needs to be requested.

MQTT does not require internet, only local TCP/IP. So, if MQTT is enabled, simply don’t disconnect WIFI on the Nuki 3.0 Pro when something is wrong with the connection to Nuki cloudservers. That’s nuts!

And if the same issue was rightfully considered as a bug on the bridge, it’s a bug.


For me this is the reason why I currently consider returning the N3P. I don’t really want my lock to request anything on the Internet. I blocked in my router at first and thought the device had a defect when it disconnected from my wifi again and again. I still have a few weeks left to return it. Would be great to have a developer response here, when this bug will be fixed.


I’m using Home Assistant and none of my IoT devices get internet access, except Home Assistant, blocked by a firewall in a separate vlan.

If I want to depend on an internet connection and foreign company servers I could use Alexa or Google Spying Stuff with a breeze.

But I paid a lot of money for network devices that are on a pro level and support things like VLANs.

So if a local working, cloudless IoT device depends on a stable internet connection and permanent connection to foreign cloud server, in which World this would be a feature and not a really ugly bug?!

Or is this like Hue, where you need a cloud account, to use the local API, for security reasons? :rofl:

Or in other words… If the ionos servers go offline / become unreachable, my local Wi-Fi disconnects and my local home automation can’t lock my front door, because it is a feature?! Really? :face_with_raised_eyebrow:

If Facebook can become unreachable (2021 Facebook outage - Wikipedia) for hours. Why this never could happen to nuki?

I hope this bug will be fixed soon. Otherwise, I’ll buy another system and no nukis anymore, what would be disappointing.


This is no bug as I think. They do want it just like that at NUKI. It’s a very dumb decision for such a device but I don’t think they will change that. Very sad but NUKI is only one of these common “cloud” devices. Cloud is needed for only about 5% of things you want to do with such a device but it is used for everything and it is even worth: you cannot do anything useful with this, if there is no internet connection (= no power). I would not even need this cloud thing at all. I have VPN. That’s enough. WIth a device of this level in HA you should be able to disable cloud and use it strictly local. But that would damage the business model of this product.

1 Like

Pls note that MQTT has problems even when Cloud is connected… and it is crazy that Nuki is not taking care about fixing it

Pls check at MQTT Automatic reconnect, force publishing - #68 by spanzetta

1 Like

This statement is completely false.

Jürgen already publicly acknowledged that the request makes a lot of sense: