Keypad "intelligent" mode does not open the door

When “intelligent” is selected for the action of the keyboard 2, a door with a knob is only unlocked, not opened.
If that is the intended behaviour, then please add a new entry like “intelligent plus open”, which allows
for alternately locking / unlocking+opening a front door with a knob.
Alternately locking and unlocking+opening a front door with a knob outside is a natural scenario, and should be available.
At the moment, the only chance to open such a door with the keyboard is to select “Open door”.
But with this setting, it is obvioulsy not possible to lock the door by keyboard when leaving the house.

Did you set your Smart Locks door fitting to “knob”?

“Intelligent” should then pull the latch when unlocking.

i just checked again. “knob” was already selected in the settings of the lock.
i now did again set “intelligent” in the keyboard settings.
did a new test, and the lock is alternately locked and unlocked, but the latch is never pulled.
seems like a bug, then…
what to do?

Which firmware version is installed on your Smart Lock?

It’s firmware V4.3.1 (SL4P)

Thanks for reporting this, we’ll look into this.
I’ll noticed you, once fixed.

In the meanwhile you could set it to “Open door” and use the back key to lock the door.


Unfortunately i cannot use the back key to lock the door, because locking the door automatically turns on the (third-party) alarm system, and i cannot allow that anyone can turn it on while someone is still at home.

I also seem to have the same issue on a brand new Ultion Nuki (aka Niki 4 I believe).

Should be fixed with 4.3.4 now.