Keypad code (without keypad)

Hi,

can I create pin code for the keypad even thought keypad is not connected? We are waiting for keypad to be delivered. I am asking just because when I try to add permission via api to user for smartlock and add code I am getting this error:

"The supplied value ‘453423’ for parameter ‘code’ is not valid"

Thanks for reply

Michal

Hi Michal!

What command did you send exactly ?

When I try sth like

curl -X PUT --header 'Content-Type: application/json' --header 'Accept: application/json' --header 
'Authorization: Bearer ACCESS_TOKEN' -d '{ "name": "PIN_NAME", "type": 13, "code": 987654 }' 
'https://api.nuki.io/smartlock/SMARTLOCK_ID/auth'

at a Smart Lock with no Keypad paired I get:

"The supplied value '13' for parameter 'type' is not valid"

You can overwrite the value for keypadPaired to true at https://api.nuki.io/smartlock/SMARTLOCK_ID/config and then set up PIN-codes like in my sample above, but there are some things you need to consider:

  • The Smart Lock will only recognize them when a Keypad is really paired.
  • So you can not see or edit PIN codes created that way in the Nuki App for now.
  • POST to smartlock/config needs all values to be sent, so be sure to not mess up any settings!

OK now it make sense because I get error with not valid type parameter so I was thinking that it is some fault on api side. I think that best solution will be wait for keypad.

Thanks for reply.

1 Like

I get keypadPaired:false even though the keypad is paired and working, why is that? Do I need to manually update config so this works (update config is also returning an error :expressionless:)

Sounds strange. There could be a small delay in sync with the Web API. Could you PM me more details on your setup so we can check it?