Keypad added but not published to Home Assistant auto-discovery


I have a SL3 pro, beta firmware 3.10.0.
It is discovered by Home Assistant, including the door sensor.

Recently, I paired a Keypad (V1) to my smart lock, which is working.
But in Home Assistant, I don’t have the binary sensor entity for keypad battery critical.

I thought it should have been published when paired.
Should I have restarted my smart lock to have this entity published?

I updated to beta version 3.10.1 so the smart lock rebooted and still no binary sensor for keypad battery critical.
It looks it is the same I had when entities were renamed for Home Assistant auto-discovery and I had to save more than twice MQTT settings to have everything published.
But if I could have a confirmation, I don’t really want to do it for nothing because I will have to rename some entities again.

Hi Patrick,
After you have added (or removed) a Keypad you need to connect MQTT again via the App-Screen to have the config topics updated.
Just open the MQTT settings screen and hit “Save” without changing anything.
Then the keypad topic should be published.

Thanks. Our previous conversation in private message made me think about this procedure but I preferred to have some confirmation before.
What will happen for the entities I renamed? Will they keep their name or will I have to rename as they will be removed then added again?

I remain there was a strange behavior where my smart lock did not publish everything as expected, don’t know if you remind. Is it fixed?

Since the IDs of the entities won’t change I assume that Home Assistant keeps the names if you have renamed them.
I renamed my Smart Lock as well some months ago and that name did not change till now although I reconnected MQTT a few times.

1 Like

Thanks, I have just pressed Save and now I have the Keypad binary sensor and I have not restarted Home Assistant but entities are OK with correct names.

I dont’t get it. What do I have to enter here? Probably the URL or IP of my Home Assistant instance but what username and password? I’m running the Zigbee2Mqtt-Addon in Home Assistant.

I have the Smartlock Pro 4.0 and the Keypad 2. Smartlock is configured via Matter. But I don’t see any Keypad.

Your Zigbee2Mqtt should send the events to an MQTT broker.
Possibly Mosquitto on Home Assistant?
The credentials for that broker should be entered on the shown app screen.

I have now created a user here in the Mosquitto AddOn and then tried again. But it does not work. Do I have to enter my IP with a specific port in the host name? Or the domain from which HA can be reached from outside?

You need to specify the internal hostname or IP address without the port.

1 Like

Worked. Thanks a lot.

1 Like

After an Home Assistant Update to 2024.6.1 and also a Matter Server Update to 6.1 my Smartlock does not respond using Matter. However MQTT works. Can’t you use both Matter and MQTT at the same time?

Because every time I try to pair my lock using the Matter Code again it says “Pairing failed”. I also reset the lock to factory settings but I still get the same error.

What else could I try to make it work with Matter again?

Strangely the connection status show this (with a Matter symbol):

Yes, you can use both at the same time.
I’m doing this since months without any problems.

Just note that once you factory reset your Smart Lock you need to remove the Smart Lock from the Matter extension inside Home Assistant and connect it again.

And yes, the Smart Lock can be connected to our servers via Thread even if Matter is not fully working.
With Matter the Smart Lock is connected the the Thread network and the Smart Lock only needs the Thread connection for connectivity to our servers.
However to operate it via Matter the Matter commissioning needs to be fully successful.

I’d ask you to open a separate topic if you still experience issues since your problem is way of the issue the OP reported and the thread is already marked as solved.
Right now every message triggers a notification to the OP as well.