Keypad 2.0 becomes slower the less you use?

I was trying to debug the reasons for my Keypad 2.0 being slow to unlock the door and I end up with only one pattern that is… the less I use the keypad it feels like it enters in power save mode and takes more time to unlock the door the next time I use it. While if I try to use it many times in a row it is always fast.

It’s sad because I remember when I bought it when it first launched it was really reliable and fast, maybe one of the firmware updates brought this bug while fixing other issue that may existed.

1 Like

There is no technical reason why less usage should make it slower.

The only thing that can change generally when using the key instead of the Smart Lock, is that the BLE advertising of the Smart Lock slows down, because the Smart Lock intelligenty learns when the door is locked/unlocked and becomes more responsive during times of usage. You can simulate that by changing the energy saving mode from “automatic” to “fast” in the Smart Locks settings.

Im setting it up right now and I’ll be back with some feedback, thanks for sharing this idea

No improvement setting it to “fast” unfortunately. The keypad is right on the other side of the door, so it’s very close to the lock, the door is made of wood and has a big double glass in the middle… any idea what can be making the keypad slower than it should be?

No, not really.

How slow is slow?
Do the LEDs signal anything different than the knight-rider in case they are slow?

I’m talking about ~2-3 seconds. And I use “slow” here because when I first installed my Keypad 2.0 when it was first released, unlocking was instant.
If knight-rider means the leds going forward and backwards, yes, thats the only animation done.

1 Like

Is there a difference in waiting time after completing the code entry (unlocking via PIN) or laying the finger on it (unlocking via fingerprint)?

I will test for 1-2 days and I will let you know

Ok, results for the first day are great, using PIN instead of fingerprint instantly unlocks.
What would this mean?

That it might not necessarily depend on the BLE connection.

How many fingerprints have you stored?
You could try to take out the batteries of the keypad, reinsert them and check if this has any impact on the behaviour.

4 fingerprints, 2 users, removing batteries or even replacing them was something I tried already but had no impact unfortunately.

Today it took 5 seconds on the first try, then it failed with my girlfriend fingerprint, then I tried my fingerprint, it took 5 seconds and then succeeded. I have no idea what’s the reason for that, 5 seconds it’s really really too much.
The current temperature is 0 degrees Celsius outside, could that be the reason?

Do you have the failed attempt of your girlfriend in the Smart Locks activity log?
The LED flashes help to identify the reason.

The Keypad is woken up as soon as a finger is detected. The first LED turns on when this happens. In theory this could be delayed by e.g. water on the sensor (due to wet conditions or ice, when it’s frozen).

Interesting… my girlfriend’s failed attempt is now shown in the logs, just the time I successfully unlocked with my fingerprint.
About the weather… not sure how to debug that, today is colder than yesterday and I just used the keypad and it unlocked in record time (less than a second) haha

It gives me the same problems too, slowness, difficulty recognizing fingerprints and flashing LEDs. It takes time to connect to the lock even though it is set to “fast”. To get it to work decently again I had to remove the batteries and put them back in, but now it’s in the same situation as before. My door is in an apartment building, around 15 degrees and the lock is 1m away.

1 Like

Same thing happening with my Keypad 2.0.

It used to be very fast, but now it usually takes 4-5 seconds to unlock. Also sometimes I need to use my fingerprint twice for the lock to react (Fingerprint → Leds do the knight-rider effect for a couple seconds → nothing happens → fingerprint again → leds knight-rider effect for a 4-5 seconds → then it unlocks).

Another strange behaviour that i’ve noticed is that sometimes the keypad won’t react to the keys being pressed (Leds don’t light up at all and nothing happens when I introduce my pin) although the fingerprint sensor still works. I have to take out the batteries and reinsert them again to have the physical keys working again.

I think the problems started around the time that I updated the keypad firmware to 2.1.3. Is there any way to downgrade the firmware?

I’ll try to set battery saving to Fast to see if it has any effects over the next few days.

1 Like

I have the same problems reported by @mallorca22 ! Very often when I digit the pin LEDs do no blink as the keypad it is disconnected from the Door but if I try to use the fingerprint the LEDs blink… In both cases the door does not open… It works only after 2/3 attempt…

It works well for a few days only as soon as I restart it, but as it is it is inconvenient and unreliable.

It’s so sad that this issue still exists, when I first received my Keypad 2.0 (at the launch) it was super fast and now I even bought a new keypad 2.0 (in the Nuki 4.0 upgrade promo) and the same delay of a few seconds happens, so it most probably be an issue out of my control, I hope Nuki give some attention to this at some point.

We are currently looking further into this topic, to get a better understanding on your systems I’m kindly asking you to answer below shown polls:

Which Smart Lock is paired to your Keypad 2?

  • Smart Lock 2.0
  • Smart Lock 3.0
  • Smart Lock (4th Generation)
0 voters

What is the currently set “Energy-saving mode” on the Smart Lock? (to be found via Nuki App: Administration/Battery/Energy-saving mode)

  • Automatic
  • Fast
  • Medium
  • Slow
  • Don’t know
0 voters

Which firmware version is installed on the Keypad 2?

  • 2.0.14
  • 2.1.3
  • 2.1.x Beta
  • Don’t know
0 voters

How far away is the Keypad 2 from the paired Smart Lock?

  • less than 1m
  • more than 1m
0 voters