Keypad 1 doesn't work with Nuki Lock 4 (but works with Nuki Lock 2)


I have Nuki Lock 2 and 4, and Keypad 1 and 2. I have a problem when I want to use Keypad 1 with Nuki Lock 4 - it gets paired fine, but when I put in the code (that is clearly correct, the one that I can see got registered for the lock via the app), the Nuki Lock 4 simply does nothing - it doesn’t unlock. Similarly, if I set to lock with the Back button, it doesn’t lock the lock… It’s registered in the app for the lock, but no action seems to have any effect on the lock. I also changed batteries, no difference. I also checked and repaired this Keypad 1 with my old Lock 2 (with which it had worked fine for 2 years), and it worked fine. So it’s just with the 4 that it doesn’t work. I tried reading it three times, no difference. The keypad is 30cm from the lock, so it must have a signal. The docs say that all generations should be working with each other:

Is there something I can do?


I have a Nuki 4 and a keypad 1, working without issues. Seems that your keypad is not forgetting the other Nuki or maybe a problem with the firmwares, let see if any developer can help you.

Thanks. I am already talking to the support. It’s weird. The keypad shows v1.6 and says there is no new firmware available (which is false according to release notes) :confused: