Interference Log vs. Connection via Matter / WLAN (Nuki 4 Pro)

  • Nuki 4 Pro works good via BT. But it’s sometimes unavailable via Matter or WLAN in the Nuki App (only in Homekit - only direct after an open / close event).
  • As I get the optional door sensor it becomes very unstable (more events in the log)…
  • I tried to Change some settings to get the problem…
  • After decativating the log, everything works fine for me. Connection via Matter works fine all the time.
  • Activating log, the problem is back again, deactivating everything is fine (Test on 4.2.6 and 4.2.8).

→ Maybe the deactivation of the log helps someone…
What can be changed to get the log working without any interference?

I have same problem with unavailable via Matter and i have 2 border routers ( Apple + SONOFF ) with Homekit .
are you testet with 4.3.2 Beta

I wait until the newest version (4.2.8) is out to write this message. Unfortunately I’m not able to install a beta when I can’t go back. But I hope that the issue helps many others to get the Nuki 4 Pro running with Matter or WLAN.

Most likely your problem does not come from having the activity log activated per se, but from the fact that there is quite a bit of data communication happening around locking & unlocking. Changed states need to be synced to various platforms via different protocols (Matter, MQTT, Nuki Web, …). The more you have active the more is synced. Maybe your network / thread connectivity does have problems with that.

If you have Nuki Web turned on (i.e. the Smart Lock syncing every activity into the cloud) you might try to turn this off (i.e. remove the Smart Lock from Nuki Web).

Thank you for your fast a good response. After I removed the lock from NukiWeb it works quite good at the moment. I’ll watch the day and look if it stays so fast.

Than I’d choose log against NukiWeb. And this would be OK because Homekit is available, too.

If you can’t fix it, can you add it to the documentation? I think that technical interested users have to deal with this problem. With your answer it’s easy to handle :blush:

How can I remove remove the Smart Lock from Nuki Web !

Login to web.nuki.io → choose your device → remove the device from the account.
In the NukiApp go to your device → settings → users → remove the NukiWeb User

→ After that the Nuki works with log activated for me the last half day. This would be impossible with NukiWeb activated. I hope you can use it, too.

Thanks for info I will test this

Thank you very much for this post.
I have the same problem using MQTT and lose the connection frequently.

Stupid question:
How to deactivate the log?
Is this the entry called “protocol” (at least in German its “Protokoll”) under Settings > function and configuration > protocol in the Nuki app? (Showing the lock and unlock events)

Otherwise, I don’t find any entry called log which I could deactivate.

Thank you very much in advance

It’s not a general problem, but specific to your setup at home. Might also be related to the problem you had with reach when the AppleTV is on. Something like “too low Thread bandwith” or similar.

The Log can be deactivated via
Your Lock → Settings → Activity Log → There you can deativate it…
But the idea from Jürgen is in my case even btter to deactivate the NukiWeb… Matter works even without it…

And yes, for German it’s the “Protokoll”!

1 Like

Hi, can you tell what kind of problems do you have with door sensor ?? I have also problems with my sensor from the beginning. Two or three times it working ok and then it indicates a closed door as open. I tried to changed sensor, mount it in different places and still the same. Now it is deactivated and waiting for some solution.

I’ve only the problem that the Nuki lock is less responding when it’s activated. But the State ist always right and with the help of Jürgen to deactivate the NukiWeb or with my conclusion to deactivate the “Activity Log” it’s all fine.

Maybe you can remove and reinstall the sensor? It works very good at my setup.

Thank you very much for your confirmation, Florian!
I will try this.

Actually, I don’t have Nuki Web activated at all.
Just using my Nuki Lock 4 Pro locally with mqtt connected to home assistant (mosquitto).

I tried activate and deactivate. Maybe there is a problem with door because there are from metal.

Anyone tested new version Nuki Smart Lock 4.3.4 Beta ( Matter, MQTT, ) stability