IFTTT no longer works with Nuki Opener

with no changes on my side, IFTTT ceased to function overnight and got deactivated. While trying to “connect” it again, the registration pop-up doesn’t take you anywhere so that the IFTTT applet stays disconnected. Please advise

Thanks for the report. This seems to currently affect several users and we are working on it and will keep you updated when you can try to reconnect again.

We were now able to fix an underlying problem today, but monitoring and testing is still ongoing. You could try to reconnect again, but I can not guarantee yet, that it is completely fixed.

wbr,
Stephan

Hi Stephan,
thanks for the update. I tested it, but still the same issue. Connection doesn’t get through.

Did you try the “reconnect” button or disconnect and newly connect again?



Hi Stephan,
I removed the applet, then picked it again, pressed connect button, received the registration pop-up as on the screenshot prompting me to “continue”, what I did, then it took me to a white screen (see the screenshot) for few seconds and then back again to the same registration pop-up prompting me to confirm “continue” again, so on, so forth. I ended up in the repeating cycle, which I just gave up upon…

@igorY You can try to go directly to Get Started - IFTTT than “Remove” and newly connect. Next step would be to activate the Applets again (which normally get deactivated if you remove a service) and this should gave you a new start to test.

I tried it too but it didn’t help. What brought me to another idea to create a new account at IFTTT and connect from there on. At least The connection worked out now. I will test tomorrow if lights work too. Thanks for your support.

I had the same issues, and for me it helped very much, to disconnect from nuki web in the nuki app (disconnect all devices separately), erase the nuki-account, and then create the account new when logging in new, in nuki web in the nuki app (all devices separately), and important when setting up the email new, dont use login over google, this messes still something up yet, so don’t use login over google, just give in the email normally without google!

@igorY If you could also PM me the new account it may help us in research. In any case, thanks for testing out and I will keep you updated.

I had the same issues. Last operated Dec 16 according to IFTTT log. Managed eventually to apparently reconnect. It was complicated, and I had to try multiple times, as IFTTT app on ios kept looping me back to “log in with user” or something.
Now “Blink your Hue lights ++” is connected, yet nothing happens when doorbell is rung.

Nuki ios app also stopped giving all Notifications I’ve permitted on both phone and apple watch, (all settings are normal) so I’ve tried deleting and reinstalling the app. I must say the process to set up app is frightfully convoluted. Why can’t I just log on with username/email and password? Creating a new web user → invitation code → fiddle with merging accounts and access rights is not user friendly, and I’m blocked by a demand for a PIN code no-one remembers setting. So now I’ll have to reset everything to factory.
This is costing me a massive amount of time and frustration.

Regarding IFTTT: Did you recheck the Applets If they are reactivated correctly?

Regarding App: This is the downside of storing authorizations locally and not forcing every user to have a cloud account no matter if she/he wants to. For sure there can still be improvements, we are aware of that.

If you have issues with push notifications you should check the settings for it in the App.
If push notifications and IFTTT both fail it can also help to check if activity log entries are correctly synched with Nuki Web as both rely on that.
The IFTTT issue mentioned in this topic is about the current disconnect problem with the integration, why this is discussed here in the developer forum. After reconnection it should still work (even though we are still working on the issue of further disconnects).

The apple watch is something different. And in general best get back to our customer support for help.

100% with you, Espen. Things used to work before and now something got changed in the code and consumer should invest own time into troubleshooting…after trying it over and over again with no result, I decided to give up…

As stated before the issue is not finally resolved. So, yes, if you continue to have problems it may be the best to wait till we have everything back to normal.

All sounds and vibrations are set to On, both in the Nuki app settings, ios Settings/Notifications, as well as Watch/Notifications. Yet the only thing that happens if someone rings the doorbell is a silent banner on the phone, one that I don’t really notice. All time spent on deleting/reinstalling app/creating new user/merging with old etc etc wasted.

Hello! When you get silent notifications, have you tried to set a other tone, maybe you get at least a notification Sound, when this silent banner comes up!?

If you got issues setting up notifications (again) best get backt to our customer support for help.

This forum is focused on developer related issues.

Certainly. I’m happy to wait days for a response that usually is “try to reset”, or “do this” without any explanation of where or how I “do this”.
If there had been a functioning end user community - not the misleading “Community” which is just an after-sales promo gig - I would perhaps have seen the problems with IFTTT there, instead of this developer forum where such questions apparently aren’t welcome? And saved some time and frustration.

Hello! Unfortunately I have to confirm the issues are back again!? It startet working for me to 95% on the 21.12., and I have quite a few triggers active where all really worked well until 2-days ago, since then triggers are again not recognised rightly anymore, and so for the Applets dont get executed!? Thanks!

Happy New year! wanted to check in on this issue and hear if you have an ETA on fixing it? @Stephan