IFTTT Integration

IFTTT allows you to connect different Smart Home services via predefined applets. On IFTTT, you’ll find numerous apps and devices that you use every day, such as Facebook, Twitter, Google Drive, Philips Hue, Amazon Alexa, Nest and of course Nuki. You’ll need a Nuki Web account to use IFTTT, since the platform connects to your Smart Lock through it. You’ll be able to, for example, control your lights or heating when you leave the house or have notifications sent to your smartphone when someone enters your home.

Setup

  1. Activate Nuki Web in the Nuki App

  2. Register at IFTTT.com

  3. Open the Nuki IFTTT Channel

  4. Activate your prefered IFTTT applet

Most Popular Applets

Hello,
I use IFTTT since I installed my Nuki lock. These last days, I constantly receive the following message from IFTTT:
" Hi f…,

We can’t connect to your Nuki.

Have you updated your password recently, or made some other changes? It could also be due to improvements that have been made to the service.

The good news: you can fix it.

Click through to reconnect."

It happened on 7, 10, 11 December and today. It never happened in the past.
Each time, I click on the link to reconnect, to re-allow IFTTT access to Nuki api.
I have other IFTTT integrations, and Nuki is the only one having these troubles at the moment.
Any idea why it happens? Something on your side?
Thanks.

This was a problem from IFTTT (sending wrong refresh tokens) which should be solved now, according to their support team.
Reconnecting one more time should fix it now.

Please get back to me via PM if it still does not work for you then, so I can check details and forward them to IFTTT support.

Hello Stephan!
I have the exaxt same problem.

The IFTTT seems to somehow deregister with nuki on a regular basis.

Any suggestions?

As I wrote above this is a problem from IFTTT and not on our side. They first told me it is solved but some users (including my own account) still have problems and they are investigating further.

The bad thing is we can’t really do anything but wait and retry. :frowning:

Okay … :smirk:
I will reconnect and see if it keeps loosing connection.

Thanks for your reply

Best regards

The IFTTT problem should now really be fixed (since tonight).

I am a bit cautious because we had thought the same before, but all affected people should please try to reconnect again and then observe the behaviour.

1 Like

@Stephan Good day!

I just tried to connect IFTTT with my Nuki Web. The authorization was done through OAuth flow.

I wonder if I decide to unlink IFTTT some day, is there any way for me to deactivate all the access/refresh tokens for IFTTT on Nuki side? On Nuki Web I don’t seem to have seen any pages for managing IFTTT like the Web API tab.

Thanks!