Huge nuki/ifttt security flaw!?

Hi! I had a event what actually should not possible to can happen!? I have nuki&ifttt setup that when the opener opens the door, the locks will unlock, - but the locks do also unlock, when the opener just activates Ring-To-Open!? The event: I drive to a shop to get some things and leave the nuki-geofence, after shopping I drive to a Relative and in the way I drive through the nuki-geofence again, this should just activate Ring-To-Open but actually unlocks the locks, in this moment coincidentally a delivery-men stands before my door because he was in the house for delivering parcels also to several other people in the house, and the door unlocks, and he opened the door! I dont need such flaws, in fact I learn now, that every time I was coming to or going or driving through the Geofence, my door was unlocking and stayed unlocked until the time for automatic relock was expired!? How can the nuki-ifttt-trigger “ring to open” fire when Ring-To-Open just gets active, it should just fire when Ring-To-Open OPENS the door, and not just going active, because this would fully contradict the sense of Ring-To-Open, and is very dangerous!? But I am aware this has to be a failure, but has also to be solved very fast! Of course I will also contact the support immediately about this, and strongly recommend not to use the “Ring-To-Open has opened” trigger for unlocking, because it fires also when Ring-To-Open is just be activated without opening anything!? Thanks!

Edit: And no, it was not because Ring-To-Open was active and the delivery man was ringing, because he was ringing upstairs, and this bell is not connected to the opener, so for triggers nothing when you ring it, just whe ringing downstairs! - And for going fully sure, I tried it myself, and I have just to activate Ring-To-Open and my door unlocks (because the false firing of the false trigger on ifttt), no matter who activated Ring-To-Open, if from Smartphone or smartwatch or ifttt!?

Edit-2: It gets even more strange, - I disabled the related ifttt-applet, but it excutes still and unlocks the door, when the opener doing any function!? - In the moment the opener does anything, the locks are unlocking, - and I looked up the protocols, and ifttt is the trigger, but there is no applet active anymore what can do this, so for inactive ifttt-applets are getting still triggered and executed!? What is going on here!?

There has been no change to the Nuki IFTTT services and there is also no known problem. Therefore please contact our support via the Nuki App (Menu > Help > Contact Customer Support) as this is an individual problem and might require sharing logs and other sensitive data.

In the meantime it might make sense to remove the Nuki service from your IFTTT account or even disable the Nuki Web User on your Smart Lock, if you want to go for sure that nothing unwanted can happen.

Hi! Right, was not thinking of that, - deactivating nuki-web for the opener, should solve this for now! Will do! Very thanks!