HTTP 400 Bad Request on first call to Bridge

Dear all,

Since I upgraded to the newest Firmware (Bridge v2.8.0, Lock v2.9.10) I am having a weird behavior when calling the API. On every first call to endpoint “/action” (e. g. I get a HTTP 400 Bad Request. Subsequent calls to /action also work fine until the system goes to sleep mode (?) and then the issue starts again. Calls to other endpoints (e. g. ) work fine.Does anyone else have this and/or is it known and planned to be fixed?

Which tool did you use to make the calls?

try giving the “deviceType = X”

Hi Hinti,
Many thanks for the hint - adding devicetype solved the issue. However, from the API documentation it seemed to me this parameter is optional and defaults to 0, which is not the case… I suggest to “really” make this optioonal as it was newly introduced in v1.9 and - if mandatory - requires all apps to be changed accordingly…

Actually, the error remains inspite of the deviceType parameter. On every first call (after a couple of hours) I get a 400 response. It does not matter what tool I use to make the call (curl, wget, Chrome browser). Anyone has any ideas?

What happens if you do any other call (e.g. /info) before the lock action? Do you still get 400?