Homekit, IFTTT and bluetooth/remote access

Hello. I have noticed few things:

Right now door is locked (I checked it manually and in Nuki app) but Homekit app shows this:


I have another door sensor on this door (beside other accessories) and it shows correct status so Homekit Hub is working OK. Is this problem on Nuki or Apple side? Do you have any other reports on this problem? I occasionally also have status Unlocking even that door was already unlocked and again locked (I can upload just one image so I can’t show it to you). This can be solved if I manually click Nuki lock icon in Home app and then status is correct (in Nuki actions logs I can see that another action was performed, so Homekit had to triggered action that status was correct).

As I say all other accessories are working OK and I get all notifications except Nuki’s one.


IFTTT push notifications are very unstable. I sometimes receive none for few hours and then I receive all of them together after few hours. I also have homebridge with IFTTT notifications and I don’t notice such behaviour (when some event is triggered I get push notification in few seconds).

Bluetooth/remote access

If I am standing next to Nuki lock (Nuki is connected to bridge) and when on open Nuki app on my phone (I have bluetooth and wifi always on) which connection to Nuki lock is active - bluetooth or remote? I have noticed that when I have both connections available and when I press unlock it takes more than 5 seconds that Nuki register my action and starts unlocking (so I think it’s connected via cloud because of such delay). But when I have my cellular and Wifi OFF (so only bluetooth is active) unlocking starts way faster (I think phone and Nuki are connected directly). Is it possible that remote access is primary and bluetooth is secondary connection when both are available?

I didn’t mention auto unlock problems because there are many topics regarding this issue (I can also confirm that is’t not working always).

@HomeKit: Do you have a specific scenario which causes always a delay? e.g. whenever you come home via Auto Unlock.

@IFTTT / BLE: This sounds very much like connection problems between your Nuki bridge and the Smart Lock. Try to position the bridge closer to the Smart Lock.

Except for a few commands that have to go through the BLE channel (e.g. Auto Unlock, firmware update) all commands are sent through the bridge. If the bridge fails to connect the command is retried via BLE. From then on all commands during the same App session are immediately sent via BLE. Main reason for this behavior is that the bridge usually has a much more stable BLE connection to the Smart Lock than the mobile phone has. Nuki Web (IFTTT) can’t fall back to BLE so it has it’s own retry scheme which can lead to delayed notifications.

@HomeKit: no, I haven’t noticed anything that I can see it’s causing problems. Today I used Lock and Go and when door was unlocked and again locked status in HomeKit was Unlocking… When I pressed that unlocking lock in HomeKit the status was correct (Locked) but another lock action was performed. I can only say that when I manually unlock it it also sometimes shows wrong status in HomeKit. If I unlock/lock via HomeKit directly then status in I think always correct (I haven’t noticed any problems yet).

@IFTTT: my Nuki Bridge (Android Huawei P10Lite) is about 2 meters away so it’s close enough right? I haven’t noticed any connection problems yet when I remotely access Nuki lock via Nuki app or Web interface (connection was always available). Even when I use HTTP APIs remotely (VPN) there are no connection problems. I sent you bridge logs to Nuki support team.

OK, so when I use Nuki app the command is sent to your cloud and then your cloud sends command to bridge which performs that action? If I make actions with HomeKit directly are actions performed via bridge also or via BLE? Is Nuki Bridge more reliable than your Android App?

Hi !

I notice exactly the same behaviour with Homekit.

The Home.app shows the door as unlocked, even if the door is physically locked.
More stranger, if I ask siri the state of the door, it says “locked”

This is moving towards a specific support case where we need logs etc. Please get it contact with our support team at contact@nuki.io.

What makes sense to do before is to try to separate the problems:

  1. Deactivate the Nuki bridge and Auto Unlock for at least a day, use only HomeKit and see if everything works.
  2. Reactivate the bridge and remove the Smart Lock from your HomeKit setup. Test again for at least a day.

Summarize your findings and send them to support.

@BLE vs. Cloud:

  • HomeKit is always done via BLE. No, Nuki bridge involved. However which of your iDevices does the BLE connection is unclear.
  • The hardware bridge is more reliable than the Android app because it is build only for that use case and tested and used in 1000s of similar setups. Every Android phone does have a different BLE chipset with different software stack and Android OS, which makes every setup with a software bridge basically unique.
  • Our servers and the bridge do only forward encrypted messages from the Smartphone to the Smart Lock and back. They can’t read them as they are end to end encrypted. See: https://nuki.io/en/blog/nuki-encryption-concept/

Ok, thank you for you answer. I cannot deactivate Nuki bridge because I won’t be sure if Nuki locked the door or not because I don’t trust lock status in HomeKit so I’m using Nuki app. I’ll try to remove/add Nuki from Homekit. I’ll wait for you to solve problem (I see that user Philippe has exact same issues). When you were testing Nuki in HomeKit you didn’t notice any problems?

There seems to really be a problem with Homekit :

The problem is that HomeKit and the Nuki ecosystem share a common BLE connection (the Smart Lock can only handle one connection at a time). While the Nuki ecosystem takes care of this, we have no influence on how HomeKit uses this resource. E.g. if it connects and stays connected neither the Nuki bridge nor an approaching Smartphone (Auto Unlock) will be able to connect. If it fails to connect to a busy Smart Lock, we don’t know how retry schemes inside HomeKit look like.

If you go “all in” on one ecosystem (either Nuki Apps or Home App) you avoid interference problems.

And yes, we’re actively looking into ways to mitigate the issues.

Since updating my iOS Nuki App to latest version, auto unlocking no longer works (it didn’t work always but it worked most of the time). I tried to disable/enable auto lock option but without success. On second iOS device which has older Nuki App version, auto unlock is working like it worked before. How can I solve this problem? Here are some debug logs:


And I also noticed something else:

Here is shown that Nuki has no bluetooth connection to Nuki bridge (and it has been a day from when I first noticed this). I’m currently far away from home and I’m able to perform all actions so connection is established. Why Nuki app says that there is no web access when there is?

Please do never post any logs. We won’t discuss individual problems here. If you want us to have a look at your Auto Unlock problems, please follow the steps decribed here: What you can do, to help us debug Auto Unlock

The information in the connection status screen is updated only once per hour by the bridge. If the smart lock has been unreachable via BLE at that exact point in time, it might appear unavailable on that screen. We’re looking into it already.

OK, won’t post logs (I am sorry, I didn’t notice this rule). Can you tell me if you are experience any problems regarding timestamps synchronisation and is is possible that this is the problem than auto lock doesn’t work (if timestamp when user entered geofence was one hour earlier because of wrong timestamp, is it possible that auto unlock is cancelled because 30 minutes interval has expired as it received correct timestamp)? Date/Time setting on my lock and on my phones are correct.

This has nothing to do with Auto Unlock. The log line just means that the internal clock of the Smart Lock was off by a few seconds and needed to be corrected (by the App).

I bought the new nuki 2.0 with Bridge. I have a iphone XS with bluetooth 5.0. I changed from version 1.0 and I hope I can use siri for open the door. But this is not really working for me. Is working only with bluetooth and not in the wlan. Is planned that this also working with wifi in future or not ? If not i will return generation 2 and use my old nuki system

It depends which Siri integration you are using:

  • Siri Shortcuts are limited to BLE only and work with SL 1.0 and 2.0.
  • Siri through HomeKit works only with SL 2.0 and wherever HomeKit works. See here for more details: https://nuki.io/en/homekit/

I removed Nuki Lock from Homekit and then tried to readd it (as you suggest eariler) to see if there will be any improvements. When I try to readd NL Homekit says that accessory is already added and that I need to reset it first. How can I do this?

Currently only by resetting the Smart Lock to factory defaults. Before you do that, please try to reboot your phone, which can also solve problems with deleted HomeKit pairings.

We’re working on a function to reset just the HomeKit part from inside the Nuki app, but this has not been approved by Apple yet and is therefore not included in the current iOS app release. However, it might appear in an iOS beta within the next week or so.

Ok, thank you for your answer. I tried to reboot my phone and home hub (ATV4) but now I get this:

Is this normal that accesory is not found?

Same for me.

Did you find any solution?

Same behavior for me with a new unit v2.

Any solution?

After rebooting iPhone, I finally pairing Nuki v2 on HomeKit.

1 Like