Homekit showing wrong status

Hi everybody, using/testing homekit on a daily basis there seems to be still some bugs.

While the Nuki App correctly shows the locks status all the time in the Home App the status rarely reflects the actual lock status.

Yesterday Home showed the whole day “unlocked”, today it’s showing on top of the favourites screen “entsperrt” while on the Lock icon within home it’s showing “locking…”…

seems relevant to this thread :

I can confirm this behavior with iPhone 7 and AppleTV 4k without Niki bridge.

I have a similar behavior. I don’t have a bridge, just nuki 2.0 latest firmware, and only use homekit on iphone 7 with atv4 as homehub. When i leave home by clicking on nuki, i receive homekit notification saying door unlocked, then when i close the door (auto lock with sensor) i receive another notification saying “door has been locked” and then the homekit status on the door becomes “unlocking” and stays like that forever. when i return, if i open the door using “hey siri, open door” the door opens normally, status becomes unlocked. When closing, i get the notification saying door closed, but status remains “unlocking” forever again. on nuki app the status is ok if i go there to check, but i use only homekit to operate the door.

I have a similar situation with Homekit showing the wrong status. Is there a fix planned, as I depend on this for a few scenes/automations.

Same for me. My lock keep displaying “unlocking” in homekit app even if the status is lock into the nuki app. I’m using Apple TV as bridge.

Did you find any solution?

Same here, can’t really lock/unlock from HomeKit, it’s stays in locking… or unlocking… until it shows the accessory as Not responding. Through the nuki app everything good

I didn’t find any solution so now I’m using Homebridge Nuki plugin any everything works fine (except little delay when performing any actions). But you will need Nuki bridge. I hope Nuki team or Apple (I don’t know who’s fault it is) will fix this soon.

Please make sure that your Smart Locks are part of the beta program (https://developer.nuki.io/c/beta-program). There will be a new firmware within the next few days, which we’d like you to test.

There is now a new Beta firmware 2.4.1 available, with some changes in how the HomeKit status is reported to Apple devices. Please give it a try and let us know if the problems you reported still persist for you.

Has anyone tested this with the 2.4.1 Beta?

Sent an email to enable my account for the hardware beta program but still waiting for a response.

We just rechecked and your SL (with the ID you sent us on 3rd of Feb) is already in the Beta group.
Please check for an update in the App manually (Manage Smart Lock > Firmware update).

Thank you, Stephan! Seems I was waiting for a trigger to inform me that I am now part of the hardware beta as well. Do you usually send a feedback for such emails? Couldn’t find any here.

@Jürgen, I just tried the new firmware and the Homekit behaviour is now exactly what I was expecting: A device, dedicated for lock status. Do you plan to add another device to represent the door opening status?


Forgot to mention: It took like 20 seconds after unlocking the door for the Homekit device to change status from “unlocking …” back to the static “unlocked” message. Guess that’s to be expected when BTLE is involved so everything should be fine here as well.

@Door status in HomeKit: I can confirm that we want to have this in HomeKit on the long run. However there’s not ETA for this.

@Up to 20s: Yes, this is “normal” because the bridge and HomeKit are “battling” for access to the Smart Locks single BLE connection after a state change. If HomeKit wins you get the notification ~3-5s after the lock state change happened. If the bridge wins it takes up to ~20s.

1 Like

i tested with 2.4.1 and it seems problem solved

1 Like

I wanted to share something I observed:
It seems that sometimes a NUKI Key will not work immediately and one needs to press the button multiple times. While I can understand the reason behind might be similar to what Jürgen explained to us above, this is something I didn’t see with the old firmware.
Might be my 2 month old NUKI Key is breaking already (as one can read quite a lot of stories about the product quality), but that’s a different story :wink: I’d rather say it is software at the moment, not about the hardware.

If I understand you correctly you mean the Nuki Fob seems to be working more unreliable with the new Smart Lock firmware?

Yes indeed, it is about the Fob, sorry… :grimacing: