Help with analogue intercom

Hi, I need some help with Nuki Opener on an analogue (Chinese) intercom. I have the intercom schema and some pictures of the circuit board. I can work out where to put the Ground, Ring, Mic and Speaker wires. I have trouble figuring out where to connect the Blue (Open) wire to bypass the intercom open button. I would appreciate some help. Thank you

Here is the schema:

Here is the photo of the board:

Hi guys, I am posting an update:

I managed to get a somewhat working Nuki Opener today. I attach a picture of the board (front and back) and I put colored dots with my working configuration so far. So I managed to get Nuki to open the door from the App and also automatically to open the door when I ring on the bell (the tests that are performed when you start to configure Nuki Opener). I highlighted the Open button with red on the picture (on the right side). So I followed the board channel to find where to put the Nuki Blue wire. There were two options but I tried with the first one and it worked.

But I have a couple of defects:

  1. When I ring the bell there is no sound coming (neither from the Intercom or from the Nuki Opener)

  2. To get it working I had to make sure the intercom handset is lifted (Even without the Nuki the intercom Open button only works when the handset is lifted). The lift indicator is the large blue/black button in the middle also highlighted in red.

For the first problem I have to figure out what might be the problem. In the Nuki configuration it was shown to connect the green wire to the RNG outlet, but I connected the yellow one (as shown in the additional documentation for Analogue generic intercoms). So the green one is now not connected to anything.

For the second problem, I suspect the Jumpers that I highlighted in red on the picture. I have to try removing them to see if that would change something.

If anybody has an idea, please comment.
Thank you

Another update to my monologue: It turns out the intercom is actually ringing. Now I only need to figure out the handset problem.

After a short test drive with the company that delivered the intercom system, the problem is fixed. I connected only the Ground, Ring and Open wires. Ground and Ring are connected where they are supposed to be. Open is connected to the Microphone outlet. This seems to make the proper connection while bypassing the handset circuit. So now, everything works as designed.