[Help Requests] Server > Bridge connection issues

Hi, there

I know this forum is aimed at developers but I’m coming here are a last resort for help.
I recently installed a Nuki 2.0 + Bridge combo.
No matter what I do or try, the bridge only stays online for 10 to 30min consistent minutes and then keeps dropping connection constantly.

If anyone can help me troubleshoot this or has gone through the same situation and can help, it would be amazing. I’ll give below as many details has I can think of.

What I’ve tried:

  1. Move bridge as close to lock as possible (picture below where the bridge is right next to the lock, still expecting the disconnecting issue)
  2. Reset bridge 2 times
  3. Gave static IP to bridge in router settings

My wifi setup if it makes any difference:

  • 3 Asus routers throughout the house, one main and 2 access points
  • AdGuard Home installed in RPi and running in DNS settings on router (I took a look and it doesn’t seem to be blocking any traffic from bridge at all)

Other observations:

  • Bridge is on FW 2.3. It has been plugged in for about 3 days and reset 2 times, new FW still hasn’t pushed through.
  • Not sure if this is expected, but I notice that the lock has some lag overall. It takes about 20-30sec to update the state and the same time to unlock the door every time. No deal breaker, but because bridge also doesn’t work, means that ever time I need to wait 30sec after opening the app and 30sec waiting for the door to unlock, just looking at it. I expected this to be done quicker…

Thank you to everyone in advance!!! :slightly_smiling_face:

Could only post one picture as a new user, here’s a screenshot of the actually app:

Looks like your bridge can’t establish a WIFI or internet connection.
Does the bridge show up with an IP when calling this URL https://api.nuki.io/discover/bridges from a browser inside your LAN?
Are all dot’s green when you enter Menu > Manage Devices > Bridge?

Hi, @Juergen, apologies for the delay, I was away for some days.

Going into https://api.nuki.io/discover/bridges gives me no bridges connected:
{“bridges”:[],“errorCode”:0}

But Menu > Manage Devices > Bridge does show all green dots:

Any ideas? Thanks so much for taking the time to help :blush:

Edit: Tried connecting to another network and call http://192.168.1.50:8080/fwupdate, bridge blinked for about 5min and then stopped. I checked and it is still w/ the same firmware, 2.3.0.

If you click on the “Bridge” icon in the middle of the screen, is “API Quickconnect” enabled?
The IP Adress will only be reported if this switch is on.

@Firmware Update: Please try it again and give the bridge some more time (ideally you leave it in the other network over night). The firmware update consists of several parts and they will be installed one after another.

Hi @Juergen, I’m happy to report that after leaving the bridge plugged for 24h on a different router and wifi network the bridge updated to FW 2.5.1.

I them reconnected to my main router and wifi network and it’s been holding strong where it previously used to drop connection all the time.

I hope this continues like this, apparently the issue was the bridge not being able to update past FW 2.3 on my network for some reason.

Thanks for all your help! :slightly_smiling_face: