!HELP! Balcom WS 20 with Nuki Opener

Hello everyone,

I have this Intercom from Balcom, type WS 20 and Im trying to install nuki opener with it. After some trial and error I still not able to open the front door, both by App or by ringing my apartment. Here is what I found so far

1 ring the front door as it opens
2 i guess this is the opener
3 speak/listen
4 ring the intercom when the button on the front door pressed
5 ???

While I managed to connect the yellow and green cable from the opener correctly,I still dont know where to put the black/violet cable and wich cable from the source should I connect with. I guess thats making my nuki opener rendered useless.

Does anyone can help? :smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear:

This is the picture before

This is what I found on the Internet

This is my configuration so far,

And still not working. :smiling_face_with_tear::smiling_face_with_tear::smiling_face_with_tear:

After hours of trials, heres what I found about Balcom WS 20

  1. Opener
  2. Loudspeaker (by pressing the button once) / Microphone (by pressing the button continuously)
  3. Ground
  4. Ring
  5. ??

And heres what I found about the cables from my intercom in their corresponding holes

  1. Blue - opener / Black - ???
  2. White (a), as there are 2 white cables - Loudspeaker/Mic
  3. Red - Ground
  4. Yellow - Ring / White (b) - ???

I had re confifured the cables from Nuki Opener

Cables Nuki Opener
BLUE - 1
YELLOW - Clamp (hole 1)

Cables from Intercom
Yellow - Clamp (hole 2)

With this configuration, I am able to send signal from my Nuki App to the Nuki Opener to open the door. It works with google home and my smartwatch as well.

But one problem persist,
I still can’t use the Ring to Open function.
When someone rings the door, it still sends signal to the intercom, but Nuki Opener dont register this event and thus wont send the signal to open the door.

Does anyone can tell what can I do to fix this problem?

What make and model did you use (in the Nuki App) as the Intercom?
The WS 20 apparently does not exist…