Force Nuki Bridge to connect to special SSID

Hello,

I think the title says it all ^^
Is it possible to tell the Nuki Bridge to connect to a special SSID?
There is a WLAN Repeater right next to it and it is still connecting to a Repeater which is outside of the house in a little cabin. Therefore it’s also always loosing connection again.

Thanks in advance for your help :slight_smile:

Hello!
Yes sure, you have just to connect it to the wanted ssid, - for example, my repeater wlan have the same name and key as my modem wlan, but on the end of the ssid the repeater has a additional _EXT, and you just have to choose the repeaters wlan, and the nuki will connect to it! No fresh setup should be needed for this, only in nuki app connecting Bluetooth with the bridge (push 10seconds on the button on the bridge), and edit the wanted settings!

Hello!

Thanks for the answer.
Sorry for the miscommunication on my side.
I have a mesh Network, so every SSID is the same.
I want the Nuki Bridge to connect to a specific repeater by mac adress.

Currently it’s not possible to select a specific MAC address. But many modern routers allow to add an “additional SSID” which runs just on one specific mesh point for exactly the reason you mentioned. Maybe yours has such a feature too.

Mhh okay :confused:

Actually I have no Idea if my router supports it or the repeater.
I got a Fritz!Box 7590 with severeal repeaters but the nearest to the nuki is a Fritz!Repeater 1200.
I may have to ask AVM directly if they have such a feature, or do you know if they have this?

Looks like the 1200 allows to generate an additional separate guest wlan, which you could use for the Nuki bridge.

See page 59 https://gzhls.at/blob/ldb/2/4/9/f/0c6b75ad32ca71968072f684318818cf5c41.pdf

Hey thanks for discovering this.
Sadly not useful for my purpose because I want to use the http API of the nuki bridge.
And the guest wlan got limitations: “Your guests receive
their own Internet access for smartphone, tablet and laptop. Access to other devices in the home network (for example, file shares, printers) is not possible via guest access.”
The nuki bridge cannot talk to Home Assistant and Home Assistant cannot talk to the nuki bridge.
Is there no API command in the Nuki Bridge to tell it which WLAN to use?

I have also a mesh with Fritz 7590 and Repeater 6000 - from time to time the Nuki 3.0 Pro loses Wi-Fi and is offline.
Never had that problem with the Nuki Bridge.

Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) as this is an individual problem and might require sharing logs and other sensitive data.

Already done - 133585 - waiting for feedback there since a week
Maybe this information regarding a Mesh is a general hint for improvement or it’s worth to take a deeper look

It‘s rather general network traffic than mesh. Recommendation is to isolate the Smart Lock from other network traffic. What usually works best is to set up a guest wlan and add the Smart Lock to it. Makes it more stable and batteries last longer.

See also:

Well I have the problem with nuki bridge :confused:
I think nuki should just bring a Patch where you specifically can define to which repeater or device it should connect.

Well guest wlan is possible for some but for others like me its not. I’m not using the nuki Cloud or the App at all, only for setup purposes. My nuki lock is managed by home assistant.

If I connect my nuki to the guest wlan it would loose connection to home assistant.

Can you setup static ip’s for clients in this fritz repeater?

Well yes it is.
But that doesn’t fix the problem, I already gave the nuki bridge a static IP in the router. As it is a mesh network it supplies that to all repeaters.

No I mean on the repeater itself, because when you set a static ip with mac on the repeater itself, it should connect to it.

Sadly not.
I can only specify this on the Mesh Master.
“This FRITZ!Repeater is part of the mesh. If you want to see an overview of the network connections and the FRITZ!Box home network and make settings, click “here” to go to the user interface of the corresponding FRITZ!Box (Mesh Master).”

Fritz!Box normally does that on it’s on with WLAN Mesh Steering… Sadly the nuki bridge doesn’t support the 11k or 11v standard… Would be too easy I guess.

Ah ok, I understand!