Door state completely inverted, lock misbehaving

Hi, maybe two weeks ago our Lock (v3) began acting weird.
We only use the unlatch function on the main screen of the app (configured on swipe in any direction), never/not the locking function or any other unnecessary smartness (lock&go or anything like that).

When the lock began it’s weirdness, it would first unlatch normally, opening the door in the process (it physically swings open a bit), but then for whatever reason, a few seconds later, turn the key for the bolt to fully extend, and stop there, preventing the door to be closed again.
Pressing the lock’s button would allow us to revert that, so we ignored it for a while, but now it’s become even more weird.

Today i recharged the battery(pack), and after inserting it, the lock went through its initial calibration it seems, but when it stopped it did so in the fully extended state while the app stated that the door was closed and unlocked (while it was physically open and the bolt fully extended).
I removed the batterypack a few times and let it do its thing again, but always with the same result.

What makes it so weird is that we do have a door sensor coupled with the lock, and it usually worked just fine, but for some reason even in combination with it, the lock’s state is completely wrong.

I’m not sure if it’s related, but our door has an unusual rest-position for the keys. The insertion/rest position is when the key is horizontal, not vertical as for most other doors (even though this wasn’t really an issue before, apart from the unlatching process seemingly using the least amount of motion possible which in rare occasions wasn’t enough to physically open the door, but so rare that it wasn’t really an issue).

It feels like a bug in the firmware, with the fully inverted state.

I hope this can be fixed.


If your Nuki Smart Lock v3 is acting strangely by unlatching and then unexpectedly locking the door or showing incorrect door states, start by verifying correct installation of the lock and door sensor. Try a factory reset and recalibration through the app to resolve any calibration issues. Ensure your lock has the latest firmware update and review app settings for any misconfigurations. You can contact to Nuki support for further help .

Thank you :slightly_smiling_face:

Thanks for your answer.
I already recalibrated it a few times with the same result.
I had no outstanding firmware updates for the lock.
The lock is installed correctly as far as it worked for quite some time with its current setup.
Apart maybe for the slight mismatch in key rest-orientation as mentioned, even though that didn’t really cause issues. And I didn’t change anything about it when it began acting weird.
I haven’t yet done a factory reset, because if that solves it then likely only for a while as this means it’s a software issue and can occur again under similar circumstances.
I’m still hoping for a better solution.

Make sure that the door is unlocked when you start the calibration.

Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) for further information. This forum is focused on developer related issues.