Can not generate a new access token from refresh token: "invalid_grant"

Hi everyone,

We are experiencing an issue with a refresh token which seems to be invalid and we don’t know why.

We use Nuki API for several customers and it works well, but for one specific customer, trying to get a new access token (because the latest one was expired) via the refresh token returns an OAuth 2 error “invalid_grant” which indicates an invalid/expired/revoked refresh token.

How can this happen and how to solve this?
If you need any ids (api key, account, refresh token), maybe I can give just a portion of them here or full more privately.

Thank you,
Kind Regards,


Our Customer Support provides timely assistance for such issues, please reach out to them with more details on the account and SL ID.

Hi Poonam,

Thank you for your answer.

Unfortunately, it’s the Customer Support who told me to ask on the forum for technical issues…
We are trying to identify why our Refresh Token was invalidated (whereas our other hosts still worked). A reconnection worked but we did not get an explanation about what happened yet.

Kind Regards,

Hi Corentin,

Thanks for confirming that your issue is resolved as this wasn’t clear in the previous message. I will reach out to you on DM for more details on this.