Bridge API: Device name showing as empty string

I am using the Opener and Bridge. I am using the Bridge API together with homebridge-nuki to expose the opener to HomeKit. This was working fine until this morning when i updated the firmware of the opener. After the update it seems the ‘name’ field for the opener is an empty string when calling /list. When I call /info it has a name for the opener.

[{"deviceType": 2, "nukiId": *redacted*, "name": "", "firmwareVersion": "1.5.3", "lastKnownState": {"mode": 2, "state": 1, "stateName": "online", "batteryCritical": false, "ringactionTimestamp": "2020-10-13T11:37:59+00:00", "ringactionState": false, "timestamp": "2020-10-13T11:37:59+00:00"}}]

{"bridgeType": 1, "ids": {"hardwareId": *redacted*, "serverId": *redacted*}, "versions": {"firmwareVersion": "2.7.0", "wifiFirmwareVersion": "2.1.17"}, "uptime": 1337, "currentTime": "2020-10-13T11:58:16+00:00", "wlanConnected": true, "serverConnected": true, "scanResults": [{"deviceType": 2, "nukiId": *redacted*, "name": "Nuki_Opener_1B7A141A", "rssi": -51, "paired": true}]}

I have tried renaming the opener via the iOS app and have also deleted the opener from the app and re-added it. Both did not change the field being empty. Unfortunately the home bridge code relies on the name field being present so this breaks it completely.

Any ideas on what i could try?


Found a field in administration with a name field, set that and now it works. will leave the topic so if anyone runs into it, this hopefully helps


Glad you found it!

In fact you always have to distinguish between the “config name” (name initially given to the device, stored in the device config and what is shown in all APIs) and the “display name” (used to differentiate devices in Apps, Nuki Web etc - just imagine you have a Smart Lock called “Front door” and get an invite from a friend who also named his device “Front door”).

If only the Opener could be integrated in Homekit natively… at least as a HomeKit Video Doorbell with restricted features in a first time.