Auto unlock too early

My Entrance to the house is on the backside. If I passed the house the auto unlock opened the door before I‘m at the door. What can I do to make the auto unlock open the door only if I‘m in front of the door.

This looks like auto unlock over Geofence is activated, because normally it should unlock just when you are in Bluetooth range. Check all the auto unlock settings, if something related is enabled!

I have this Problem from the beginning using NUKI for years. Sometimes timing is good and door is open but often it opens to early and door is closed till i could open. I tried to change the expert settings with Bluetooth Range but I could not find a Solution.
The crazy thing is, that it works one or two weeks without a Problem and then it didn‘t work without any change. This is a frustrating Problem with NUKI and I can‘t see a solution.

You can try use the expert settings for auto unlock and have it require a higher RSSI value (be aware that the values are negative). So if you set the value to -60 you’d have to be closer to the door to trigger the unlock compared to if it’s set to -90.