Auto-unlock takes a few seconds to open the door when I'm next to it

I’m using Android and running the latest version (11), Nuki app is up to date and so is the lock firmware (2.10.8), HomeKit is disabled.
After entering the geo-fence and walking up the stairs, I sometimes find myself waiting 5-15 seconds for the lock to get unlocked via the “Auto-unlock”.
I did notice the “Energy-saving mode” that is currently set to “Automatic” (default).
Will changing it to “Fast” make any difference?
Thanks

Hey @Sagi !

If I remember well, then the “Energy-saving mode" refers to the frequency at which the Nuki Lock and Bridge communicate, so I would say that it depends on whether you are using the Bluetooth or not.

I mean I’m not a user of that feature, but do you have your Bluetooth turned on when this happens?

Just an FYI side-note

I’ve experienced more important timing delays with the Android devices than the iOS ones.
Though I admit this is no solution to your problem, just maybe something you should know.

Cheers,

David

To my understanding the auto-lock feature works with Bluetooth, i.e. it looks for the lock using BT and unlocks it when it finds and able to connect to it.

Yes.

I assume you are right and Android does take naps more often :frowning: I’d still expect the Nuki app to somehow wake it up once I’m inside the geofence radios.

The feature doesn’t worth much if I have to stand 10 seconds outside my door waiting for it to unlock…

Well it seems like you know it better then me in that case :slight_smile:

But also based on this, I have no idea what the solution to this could be, especially, because if the frequency is based on what the Android OS allows, I’m not sure what can be done about that (though I’m no app developer, probably other people could have a solution to this).

But surely, I understand that with the additional wait, there is no real use for it :confused:

Cheers,

David

It depends.

  1. You need to make sure that the Geofence is not the thing that delays the Auto-Unlock. You can check in the AU “Last Autounlock” Section if there was a significant time difference between “Geofence entered” and “Smart Lock found”. If this is less than 15s, your problem is the geofence and not the BLE connection. Increasing the size of the fence can help in this case.

  2. If it is BLE you could try to unlock your phone while you approach the door. If you get an instant unlock, setting the BLE speed to “fast” could help. Technical Background: Most phones have very restrictive BLE scan intervals when they are in the Background. This can lead to a delay until the Smart Lock is found. When the phone is unlocked, it will use much more aggressive scan intervals and therefore find the Smart Lock faster.

  3. If you have a relatively large timegap (>15s) between “Smart Lock found” and “Auto Unlock executed” your phone has a problem in connecting to the Smart Lock and sending the actual lock command. What you could try in this case is to decrease the range for the AU to happen in the AU settings. This will make your phone wait longer while you approach the door (until the BLE signal from the Smart Lock is stronger), which can increase the speed at which the connection establishment is done and thus the lock command is successfully sent. Sounds counterintuitive, but sometimes less (distance) is more (speed).

2 Likes

Thank you, Juergen.

How much more energy will the “fast” mode produce?

Edit, today I’ve encountered a longer than usual delay, here are the “last auto unlock” events:


I haven’t yet applied any of the suggestions above.

@Juergen is this legit? should I collect any logs for further investigation or following your suggestions should get this fixed?

About 1 month less battery life.

Your problem is case 3 above. You should try the suggested steps.

mmm I can’t reduce the AE radius, it’s already set to 100m and that’s the minimum for Android…