Auto Unlock - Samsung - Android - not working - Auto Unlock funktioniert nicht

Hello,

I recently received my Nuki 2.0 with Wifi Bridge - on 28 Jul 2020.

Set up was relatively straightforward. However, after the initial honeymoon phase, I am finding myself already, after a day, frustrated with the device.

Auto Unlock isn’t working reliably - or simply isn’t working at all
-Leave the geofence, enter geofence and go to door without touching anything on my phone during the whole process = no auto unlock
-Leave the area, use phone, enter the geofence, use phone, make sure phone is unlocked and screen is on as I was towards the front door = worked once, but not a second time
-Leave the area, use phone, walk towards the house with screen on but not unlocking or pressing anything = worked once, but not a second time.

I’ve also tried all this using the Beta version as well as prior to Beta.

A second issue is trying to update the firmware - also a nightmare - the only way I got it working was unplugging the bridge, rebooting Nuki and phone and then press retry a couple of times for the firmware transfer and then eventually it worked. Nothing improved with the auto unlock.

I’m almost at the end of my tether right now with the device or its compatibility with Samsung/Android - whichever is at fault. I’ve checked to ensure that Nuki is not being optimised for battery usage.

Hopefully I’m the only one with this issue and the fault is that I’ve managed to install something incorrectly, or missed a setting, since there is very limited information on the Nuki website about what do when this occurs, however many people with issues from 2018 and 2019 in the forums, often resorting to a third party app.

If anyone has previously had this issue but not anymore - I would love to hear from you! Since tech support have had this issue in the forum a lot till now, please let me know how to resolve it, or how it was resolved for other users.

Samsung 10 Running Android 10 and One UI 2.1

Many thanks,
Ammo

Similar issues here with Samsung Galaxy S7 Edge.

I’ve asked around and a friend of mine based in Germany has the same issue with the Samsung S9 - only unlocks when the phone has been unlocked first, and not always reliably.

I’m beginning to wonder if any Samsung phones can use the Auto Unlock feature at all. If someone has it successfully working, I’d like to hear from them too.

Hey,

Samsung is most Times absolutly horrible with battery Management. Hibernating Apps eben when they are running. They have also done this with the Covid19 Tracker App.

I can recommend the “Don’t kill my App” - App from Urbandroid. There is discribed how to Set all of those “intelligent” energy optimations off. Also you can make benchmark to see if the Apps still get killed. If all is turned off, and the benchmark still negative, I guess theres nothin more than you can Do besides installing a custom ROM.

Hello,

Thank you for your reply.
If you yourself are using a Samsung phone - does the Auto Unlock feature work for you without having to wake up your phone? Now that you are using the don’t kill my app steps?

I’ve checked the settings in the “Don’t kill my App” -app, I’ll see if they work, but these settings were mainly about “Sleep” and I’m not sure that applies for an app that was used within the last hour… leave house, go to the supermarket, come back…

Regardless, I already have battery optimisation off for the app, so it doesn’t even show up in the sleep app settings within One UI.

If the steps from Don’t Kill my App work - then maybe it’s best for Nuki to add that to the help area. The steps I found regarding battery optimisation, I have already performed.

I will try the Benchmark and see if that helps clarify anything.

I sent my logs to Nuki the other day and obviously there is this thread.
So currently hoping to get a response on that.

Hi,

for me I have an Galaxy S10 and after setting all optimizations to off Auto Unlock is working quite good. But I think maybe there are differences between models and Firmwares.
I think also Samsung Does not only kill the app but also the network and Bluetooth communication intervals on a Firmware Level. I have seen with other BLE products they can have same issue than Nuki. Specifcly there is the point of the “Energy Mode” in the settings. There must be the highest Performance enabled I think.

I have an S10+ and finally I use 3r party APP Doorman… It works perfect about 99% of the uses

BesenWesen thank you for this, if you have time to make a quick summary of which apps you’ve turned battery optimisation off for, I’d appreciate it.

I already have Nuki with battery optimisation off and currently my battery profile is optimised. I will try with the high performance profile, but possibly you’ve taken other apps out of battery optimisation such as bluetooth?

Hello there, thank you for your advice, I have noticed there are a lot of people in past posts mentioning Doorman, and have seen posts where Doorman offered to help Nuki.

I might try it. However, this thread was started not only to get some community feedback but to get some feedback from Nuki. I have an open customer service ticket with them too, as yet no response.

Surely someone at Nuki has a Samsung phone and has managed to find the settings that work as reliably as any other type of phone? If there’s a simple list of things to check, then I’m happy to go over that, perhaps I’ve missed something.

Or perhaps the official Nuki recommendation to use a 3rd party app?

Hello @Ammo, thank you for getting in touch.

Regarding the auto unlock: when you leave your geofence (lets say its at 100m) we also take the accuracy into account (lets say its +/- 20m). In that scenario you have to be 120m away from your device plus a certain time where we make sure you left the fence. (To avoid re-entering the fence quickly). So, if your accuracy is high, this impacts the exit. (That’s a very basic explanation.)

For security issues we perform the auto unlock over BLE to make sure your are near the lock to avoid an auto unlock if the geofence enter is too far away (accuracy of the location).

As @BesenWesen pointed out, it also depends on the manufacturers implementation of Android (power saving, app background, sleep, …). All these and many more effect auto unlock: geofence exit/enter with the given accuracy, app running in background to perform updates/BLE commands.

You should get an answer from your support team.

Regarding your firmware update issue: from which version did you start the update? Did the you have problems during the transfer or while installing? Please get in touch with your support team for further assistance and attach the debug log if it was enabled during the firmware installation.

Hello Stefan - about the Firmware update - I decided to turn off the wifi bridge etc in order to perform the firmware update because I saw this suggested by another user. The update via bluetooth directly worked ok, so it kind of felt that the previous firmware wasn’t ready for update via wifi bridge, although they came in the same box. I had issues whilst transferring, Error 813 and I think maybe 506 during the same process. Without the wifi bridge, and standing next to the lock, it worked eventually after restarting phone and Nuki. Unfortunately I didn’t note what the previous firmware version was.

As for my issue with the Auto Unlock, I’m leaving the area and driving elsewhere kilometres away then heading back, I’m using my phone whilst I’m away, then heading back, and as described in my initial message when I come home, nothing happens unless I pull out my phone, unlock it, and wait- whilst standing directly on the other side of my door. And often this doesn’t do anything either, so I manually unlock.

I look forward to getting a response from the support team, as it’s clear here the issue affects seemingly most Samsung devices, and a number of existing customers, with posts going back to 2018. I was hoping someone had by now come up with a list of things to check from the Nuki side? Like a simple idiots guide to the settings. I can imagine I’ve missed somethig.

Very appreciate any responses I’m getting! However, I’m becoming a little concerned, and I’m hoping the issue is purely just a setting which Nuki could communicate to me - is there anyone within Nuki who has Auto Unlock working for a Samsung phone with One UI or is it also a known issue within Nuki?

Likewise, are there any customers who definitely have it working and can share their settings?

The firmware is installed with the app over BLE not over the bridge. The reported errors suggest a timeout, maybe caused by standing too far away from the lock. Wit a log file a more detailed analysis is possible.

A manual unlock wake-ups several services and also (maybe) triggers the geofence (update). When it’s fast enough, an enter is detected and the Smart Lock is found over BLE the auto unlock is triggered. This could also not triggered and therefore no auto unlock is executed.

Please have a look at the following articles:

How does Auto Unlock work?
Optimising Auto Unlock
Information on the Smart Action Center

As written before, it depends on several factors which impact the auto unlock. Its very individual.

Ah ok - I and a few others assumed that firmware updates could be performed via the WiFi bridge. I guess I should’ve read the manual properly.
From what you are saying, update over wifi is not a feature of Nuki. In the future I’ll make sure I’m in Bluetooth range. I’ll also let my friends know to be in Bluetooth range when updating theirs, since they reported the same issue.
Thank you for clarifying that.

Yes I believe these were the articles I followed when trying to troubleshoot the issue after installation last week. So after checking my phone and Nuki settings, I haven’t changed anything, but if it works reliably in the next few tries, I’ll report back here.

For today’s testing, I’ve actually left the country - which hopefully is far enough out of the geofence zone.
As per the links:
-wifi has been on the whole time
-Nuki app is not being battery optimised

-Auto lock info screen currently correctly shows me as not at home and waiting for me to approach my home
-Smart warnings and notifications are toggled to on.
additionally
-phone battery profile is set to high performance mode, so battery saver settings are off
Based on the above I understand, auto unlock should eventually trigger when I stand in front of my door when I come home? If there are further tips or things for me to check please let me know.

It would not shock me if the issue is purely my inability to set up my phone and NUKI right, but I’m checking and checking that my settings match the website. The issue could be with Samsung, and I can imagine this is then deeply frustrating for NUKI.

Based on the quoted statement, is it safe to say that Auto Unlock does normally work for Samsung phones in general with the same performance as on other phones i.e. iPhone? This was basically one of the questions I’ve asked a few times till now.

I absolutely understand the likelihood that it depends on several factors, which is why I was hoping for a list of things to check which have solved the issue for NUKI employees or customers with Samsung phones (other than using a third party app).

Customer service has my log files, I’ll look forward to an answer there and then report back here and really welcome any responses to the above from NUKI or the wider NUKI user community using Samsung devices.

When you enter the geofence, the Nuki app starts to search for the Smart Lock over BLE for a given time. When it has been found the unlock is executed.

Your could enable and disable auto unlock - this re-registers the geofence with Android (you can give this a try when there is no enter or exit on the info screen).

Also check if location permissions are correct. Reset the “Expert settings” to defaults:

  • Geofence size: 100m*
  • Auto Unlock active for: 20 min
  • Auto Unlock Speed: Normal

*) A too small geofence might lead to auto unlock execute to late.