Auto unlock doesn't work good when Bluetooth InEars are connected


I’m using the Nuki Smartlock 3.0 with the Bridge and the Auto Unlock Feature works well when no other Bluetooth Device is connected. I optimized all Auto Unlock settings in the Nuki app and added the Nuki App in the energy settings that the app can run in Background.

As I said the SmartLock works well when no other device is connected but there must be a solution that I can hear outdoors music and come back and my SmartLock works good. Any ideas?

I’m using a Google Pixel 6 Pro (Android) phone.

It seems like the bluetooth scanning interval is reduced while another device is connected?

I hope one of you will have a good solution for me.

Kind regards