APP UPDATE: Nuki iOS App 2.9.0-Beta

We released a new iOS app version 2.9.0 Beta .

What’s new?

2.9.0 (2118) Beta 1 - 30.07.2021


  • Secure and easy Nuki Web login: Benefit from even higher security standards with the new login to your Nuki Web account.
  • Amazon Alexa & Nuki: Now you can connect Nuki and Amazon Alexa directly in your Nuki app and control your Nuki devices via voice control.
  • Your security and privacy are our priority! We provide detailed security and privacy information in the Nuki app.


  • fixed an issues with (un) lock actions on Garmin watches
  • several bugfixes and performance improvements

Please update your Nuki app and give us your feedback!

I still face the issue that I cannot see the status of my SL from remote or open my door from remote with the iPhone, but this is also an issue in the standard release channel. Not sure since when this is existing. Bridge access via Bridge API and also access via Nuki Web works, so it should be an issue with the iOS app.

Try this:

  • In the Nuki App go into Smart Lock > Settings > Connection Status > “i”
  • Click on “Disconnect bridge”
  • Navigate back to the main screen and close the Nuki App
  • Open the Nuki App and check if remote access works now
  • If not, try to go into Smart Lock > Settings > Connection Status > “i” and click on “Connect bridge”

I cannot disconnect the bridge

Remove the Smart Lock (Smart Lock > Settings > Delete) and add it again to the App.

How and where should I login to my Amazon account?

Ok, that solved the issue with the beta app. I ll have to check if it also helps for the standard apps, but I assume so. Thanks @Juergen . @Stefan_A : case closed!

Hello guys!

When will we be able to open with the “opener” using just our Apple Watch LTE connection?

Thank you

When exactly do you get the error screen?
You should directly be redirected to the Amazon sign-in when you start the linking process in the Nuki app.

Directly after entering Administration menu and selecting „Amazon Alexa“. On the first attempt I was redirected to Nuki Web and logged in, then the error screen appeared.
Now I get the error screen every time when selecting „Amazon Alexa“.

Please check in your Alexa app if the Nuki Smart Home Skill is active and if the Nuki device is available?
And also if the device is available in your Nuki Web account and if locking via Nuki Web is possible.

Lock and unlock possible via Alexa and Nuki Web, see Screenshot

Error in Nuki app still present

Could you give us an update on this, please?
Thank you

We are currently working on a solution for the issue and will inform when a retest is reasonable.

Thank you!

We just released a fix on our sever, can you please test it again.
Does the error screen disappear when clicking on ‘Try again’?

If this doesn’t work, please deactivate the skill in the Alexa app and try the linking again via the Nuki app (if it fails you can still link it via Alexa app).

Doesn‘t help, even after deactivating the Nuki skill in Alexa app. Error message still the same.

When selecting retry, I only get an empty screen with only one selectable action „back“ on the top left corner which sends me back to the administration menu.

Please send detailed information to our support - go to the Nuki App (Menu > Help > Contact Customer Support). Then we can take a closer look into the app error logs.

Done, incident no 106613

1 Like