App: Entering MQTT data

I would like to try out the MQTT feature.

the App only supports hostname, not IP.
the App only supports hostname, not an other additional port (1883 is used by another MQTT-broker)


instead of the hostname you clould also use an IP address, so I do.

Port 1883 is fix at the moment and you can‘t change.

Tried several times by using the IP, every time I get as a result:

“Die Aktion konnte nicht ausgeführt werden. Bitte versuche es später”
(sorry, don’t know the wording of the english report)

Another IoT device is running on this MQTT broker, so it’s a Nuki problem

Could it be that you must be near the nuki itself? I did this today and faced the same error message several times here in front of my pc in another room (although the nuki is in my wlan). When I went to the door the nuki is installed at it worked suddenly…

it’s about 80cm between my smartphone and the Nuki

I get the same error (in Dutch “Deze handeling kon niet worden doorgevoerd. Probeer het opnieuw”). I use the MQTT broker on my Homey (which is the Aedes MQTT server) which is running fine and is accessibele by other clients (default port 1883). I specify the IP-address in the NUKI app instead of hostname.

Updated the lock to newest beta firmware (3.6.5) and added a local DNS record for homey (homey.home). I can ping to homey.local from other network clients succesfully and I’m able to login on the MQTT broker.

Unfortunately still not able to connect from the NUKI app…

Final update: integration works fine when I use a temporary Mosquitto server on my laptop. Both through IP and hostname. Seems like an issue between NUKI and the Homey Aeres MQTT server. Any way to access the NUKI MQTT logging? The Homey Aeres MQTT server gives no entry of a failed login, even in debug mode.

de- and reinstalling the App fixed my problem using the IP.