Any API requests results in a HTTP 503 Unavailable


I have the same issue.

Connection of the Bridge is okay:
–Ich darf als neuer Forumgs-User nur ein Bild in meinem Beitrag posten… nunja…–

API setup of the NUKI Bridge is also okay:

Any API requests results in a HTTP 503 Unavailable

  • curl
  • curl
  • curl
  • curl

EDIT: I tried the info-Request in a while loop with 1 sec. delay round about 300 times… every request results also in a 503.

Nuki Bridges runs Version 2.1.20 and the NUKI Smart Look V2 is updated today.

Any ideas, why the API is not working?

And is there a way, to debug the API? I could not found anything in the documentation.


Good guess from @creak here. Looks like you got the new hardware-revision.
If you want to start using the HTTP-API asap please contact our support at for a quick exchange of your device. Else you will have to wait for a FW-update .

1 Like


okay - if the Nuki-Bridge ID ist the same as the Serial No. my starts with 15. So it seams, that I got a brand new hardware with only part of the software working correctly :frowning:

For privacy and security reasons I don’t want to use any of those fency cloud services and I loved the idea having a bridge with local API that is usable inside a separated automation network under my control.

What’s the ETA of the new firmware? Or is the exchanged hardware also one with the new HW revison including the API or the older HW revision? Are there any information available about the diverences of the old and the new bridge HW? :slight_smile:


Yes, you got a new hardware-revision.

That’s why we offer that solution. Unfortunatly the very high demand for our Bridge lead to that situation where we had to take the risk to ship this new revision with not yet ready HTTP API; and obviously even more people than we thought are using it! :wink:

Unfortunatly I also can’t give you an ETA yet. So if you want to be on the safe side we offer you an exchange to the previous hardware-revision. The difference is the chipset, which mainly means we use the same BT chip as in the SL v2, but features/functionality are the same in both versions.

If you want an exchange just contact our customer support at for a quick replacement.

Thanks for the information about the the to bridge versions. So it seams, there are not that mutch differences between the both versions concerning functionality (except the running HTTP-API). If will contact you via e-mail for an exchange.

hello i have recently buy à doorlock v2 with bridge but the bridge api on my bridge return allways error 503 Unavailable but in my phone all are correct and on nuki web interface no problem all work. what wrong ?

Did you see

If your Bridge ID starts with 14 or higher we could add it to the Beta group, which should solve the issue.

P.D.: Also (if the above is not relevant for your case) always be sure to not call the HTTP API from a normal browser, to avoid 503 errors

yes is the id is 15… and firmware is 2.1.34 do you want sent you in private message the id of the bridge ? And i use Curl PHP curl in a raspberry pi. not in a browser

Please send it to or as PM.

Becomming Nuki-Bridge beta-tester solves the missing HTTP API on the new HW revision. Firmware Version 2.1.37 brings “back” the API :slight_smile:

Thx for your support - Chris

1 Like


Thanks for your feedback. Good to hear it is working now. :slight_smile:

I also split out this part of the topic where it was a new hardware-revision bridge and not those irregular 503 errors the other users h. So users with the same issue should find the solution even quicker.

Update: The new Bridge Firmware is now public and there should be no need any more to join Beta just to get access to it.
Note that the update runs automatically, but can take up to 25 hours.

Is it possible that the current HTTP-API on the new HW Bridge running FW version 2.1.37 doesn’t support all features listed here (

e.g. curl 'http://192.168.X.Y:8080/lockAction?nukiId=<ID>&action=open&token=<token>'
or any other listed lock actions return a HTTP 400 Bad Request.

EDIT: solved… wrong interpretation of the “Lock actions” list. Using the int value and not like suggest the “enum” vlaue. Lesson learned: Not everyone uses enums :wink:

1 Like

Thx for the feedback anyway. We will try to improve the documation to be clearer on that.