Upgrade Trouble with Firmware 2.5.1

Hello everybody,

as a beta tester for the Smartlock I was offered the firmware 2.51. The installation ran flawlessly and the SL also worked. After a few minutes, the SL can not be addressed, neither app nor by bridge. After restarting by removing the batteries, it will be back for a few minutes. That can be reproduced. It seems to fall into a deep sleep from which it does not come out anymore. How can I roll back to an old firmware? Should I reset the SL? I urgently need a flawless firware. With the previous firmware 2.50 I had no problems.

Thank you for the quick help

Best regards Markus

Since the SL is indeed no longer responsive and thus also useless and functionless, I have carried out a factory reset. The keypad and the bridge newly trained. First of all, everything worked. After about 15 minutes of inactivity, the Bluetooth from the Smartlock seems to be deactivated and thus no further communication with the device is possible. That’s not funny. I would be very grateful if you could fix the problem quickly.

Best regards Markus

Have new insights now. After a factory reset it works (for 2 hours) if I do not embed the keypad. As soon as I integrate the keypad, Bluetooth deactivates after about 5 minutes. Then it does not help if I unpair the keypad. At the moment I do not integrate the bridge. For me, only SL goes to factory reset without keypad. This is certainly not the setup that I wish. I hope for quick troubleshooting by Nuki.

Hi Markus,

Thanks for your input, we’ll try to reproduce this based on your setup.

Did the smart lock stop working after 2 hours or did you pair the keypad after 2 hours and the smart lock may have worked longer?
In those 2 hours, did you just check the status of the smart lock via app or did you perform any lock action too?
Afterwards, did you just pair the keypad or did you perform a lock action via keypad too before the smart lock stopped working?


Hi Marc,

The 2 hours mean that the SL ran until 21:00 - 23:00 without errors. It is still running this morning :slight_smile:

I use the following Test Scenario:

  • Factory reset of the SL without pairing the keypad.

-When I couple the keypad to the SL, then everything works first, after about 5 minutes of inactivity (no app use, no button press) disappears the Bluetooth connection, so that neither the App can communicate with the SL nor the Keypad. The timer and the button are still working.

  • When I remove the batteries and put them back in, then it works again. After 5 minutes of inactivity the same symptom

  • only after a factory reset of the SL and pairing the keypad it seems to work longer term.

  • Did I pair the keypad or run a lock action? I can not remember exactly. Both one and the other would be possible.

Best regards Markus

Unfortunately where were yet not able to reproduce this.

When the smart lock stopped working, was it in locked or unlocked state?
Did you calibrate the door sensor too?

Is removing the batteries and inserting them again the only way to activiate bluetooth again or does waking the smart lock by turning the knob or pressing the button help as well to keep ble active for another 5 minutes?


Hi Marc,

The smart lock was in unlocked state


No, pressing the button or turning the knob does not activate bluetooth again. The LED ring lights, but Bluetooth remains disabled.

regards Markus

same for me. Using SL 2.0 with Beta 2.5.1, HW-Bridge and Keypad. SL looses BT Connection to Bridge and smartphones. So i can’t open the door without key. Will describe the problem in detail in the evening. Is it possible to go back to a stable firmware?

So it is not safe to update in this beta version? Please i want official answer from developer team. I know it is a beta version but if critical error will come, then it is alpha version!

I integrated the bridge last night. So far everything is running. Tonight I will integrate the keypad again and report afterwards.

Regards Markus

Hi Grigorios,

We’re still investigating this and were not yet able to reproduce the problem.
But we’ll try to address this in the upcoming 2.5.2 release, so you might want to wait for this release.


Hi Matthias,

The problem seems to only occur if HomeKit is disabled.
Did you disable HomeKit?
If so, please try to enable HomeKit.


Homekit is disabled indeed, because i don’t use any apple devices. Will try enabling tonight.

Enabled homekit yesterday. Now it works again without any problems.

So by this trick everything is ok in this version? I am ready to try it :slight_smile: !

The current 2.5.1 version contains a fix for this. If you update now it will work even with HomeKit disabled.

Thanks for the fast reply.Up and running! Btw is there beta update for nuki bridge as well? Because it keeps going offline after some days and needs to replug it for fixing it. Thanks