Smart Lock offline

I believe that problem is with Nuki Brodge, not in Firmware of lock.
I have lock with firmware 2.3.11 and it was working very good with Bridge 47/2018. Now I tried to conect lock with Bridge 10/2019 and there is a problem, the lock is Offline.
Whats is wrong with Bridge from 2019?

This is not a Bridge, I changed it and it still dosen’t work.

1 Like

Surprisingly, silent and no feedback -:frowning:

@matt Sorry if you didn’t get feedback from our support yet. I can’t see status of tickets there.
Regarding the Bridge where have been some updates (beta and public) lately which roll out automatically.
Regarding Smart Lock firmware, where will be a new public version soon, but we can’t roll out updates as easily as with the Bridge, as a manual interaction is neccessary. That’s why we ask users with current issues to go for Beta to for faster access to fixes.
And, yes, even if our support feels slow and unresponsive to you please keep them updated with your issues and logs files to help us solve your issues.


Just two quick things from my experience with this issue - nuki offline.

  1. Try and replace the physical Nuki Bridge with the Nuki Software Bridge android app ( that you install on an old phone and leave it within range. This way you can confirm/eliminate the physical bridge as the culprit. Don’t forget to disable Battery Optimisation for the Nuki Software Bridge android app and activate “Bluetooth restart in case of an error” and “AutoConnect” in the app. You can further optimize this by also inserting a SIM card in the phone and using a mobile data connection; this way you can eliminate any possible problem with your home WiFi such as misconfigured or defective routers, firewalls, shaby internet connections, what not. This is not an assumption that Nuki is not be blamed or that you do something wrong: it’s simply an easy test to eliminate as many possible problems as you can.

  2. One thing that happened to me was that i kept seeing not many, but a few Nuki offline situations. In one such situation i had to quickly open the door remotely for somebody. On my phone Nuki was showing offline so i grabed my wife’s phone. With my wife’s phone it worked instantly. But on my phone it still showed “Nuki offline”. It was then when i realized that i have a DNS based ad blocker on my phone which somehow interfered. I deactivated it and got back Nuki access instantly. Kept following the situation by activating/deactivating the DNS based ad blocker and checking on Nuki: sometimes it can access it just fine, sometimes not at all, but when i deactivate my adblocker it ALWAYS works. Now this is about the phone app but i am thinking that if i setup such an adblocker on a router level in the same location where the smart lock is this could just as well interfere with the remote access. Try not to use any very specific DNS settings - like OpenDNS, or parental controls, or stuff that implicitly tries to protect your network, because even if minimally configured or left with default settings it could block access.

I am not saying this is what causes the offline problems for you guys, but i thought i’d share my experience, maybe it helps anyone.

Kind regards.

An other day, where the Nuki goes offline. Sorry, product is useless as the trust is gone

It would be interesting to find out if it’s a remote access problem or a smart lock problem. There are two things you could try, if willing:

  1. if possible, when you are away and Nuki shows offline, IF you have somebody at home (father, mother, wife, husband, whatever) you could ask them to try and access the smart lock through bluetooth.
  2. reset the bridge and during initial setup enable developer mode and note down the IP, Port and API token. Then if Nuki goes offline again log in remotely to your home network and try to reach the bridge on your LAN ( - see the /info command).

The basic idea is to find the right culprit. It may be the bridge, the smart lock, both or something completely unrelated to Nuki. The only solution is a step by step approach and elimination.

Hi Johannes,

thanks for the try. On point 1, I can confirm that the Nuki is offline and not available through Bluetooth.

Waiting on the event, when it goes again offline to test point 2.
Will keep you updated.

12 Days no reply from Support.
This is not acceptable.
Even If, as I hope, it is a small part of customers that have this problem you should provide then a solution or at least a valid workaround.

This is not acceptable and, as in the same way I provided positive feedback on the many automation blogs and fora I am in at international level, I will start provide negative feeedback from now as it is neither solved nor taken in proper consideration from a customer care point of view.

I am sorry but I had all patience and offered collaboration. In exchange I received slow feedback (if any) and no solution.
I am not talking of this forum were there is no SLA and of which I know the limitations but of official customer support.

Still no reply.
Is this customer care?

No, this is not what should happen. I will relay this once more and can only apologize again.

1 Like

Mine went offline twice, after about 5 days.
No keypad, no app, no bridge.
Battery removal fixed it.
SW 2.4.5

connected via FHEM
NUKI web

Thank you . I appreciate your effort and presence .

I have Been recontacted.
For the sale of correctness i post my reply


I apologize I have read now that you do not guarantee the proper working of the bridge with the app on your site.

If I May suggest make that notice more evident.

In the meantime since I have a zigbee (Alexa) hub May I ask if.there Is any plannto integrate It (i.e. using It as a bridge)

I Will keep trying to troubleshoot my setup.

Having tried with multiple android mobiles (lg Samsung) I think It Is dependant on May home network.

I Will try to put the phone in dmz.

Question: Is there.some Port that must be open?

Thank you



I am having a similar issue.

When I first set it up, everything was great and it was working fine, no problems apart from battery changes. Had invited family members and it was working remotely for them too.

However, my phone broke and I needed to replace it. In the interim, I factory reset the bridge & the nuki and paired it with an old phone, sent the invites to my family members of which, it was working again.

However, when I am remote, it shows as offline, when close or within proximity and our phones are connected to the wifi and/or to the Nuki via bluetooth, the Nuki works. It does not work however via data/remotely.

I have tried factory resetting multiple times to no avail and similar to Nicola Reina above, this is a real pain. Up until now I thought the Nuki was the best thing ever but if I can’t get this fixed or if the problem persists, it’s going to be a major issue for me.

Even worse is that I am on the road a lot and can not be present to troubleshoot and need one of my family members to do it.

I have tested being connected to the wifi/bluetooth/data only and it works via wifi only, bluetooth only (& both wifi or bluetooth) but not data.

So everything is connected and working but only within proximity, no longer remotely as before?

What could the issue then be?


Would really love a response.


Sorry, I seem to have missed this post beneath the many ones coming in that weekend.

Best would be to send a log-file with a short description of the problem and the exact time when it occured to our support team at, so they can check the details of what happend.

Our support team tried hard to catch up with all the demand so you should not have to expect as long response time as we used to have.
In any case it is best to send them log files where we can check the errors and get back directly to you with further questions. (It would be especially interesting if in your usecase the App uses Bluetooth-fallback when in the Wifi. - You could quickly test it yourself by trying to deactivate bluetooth when connected to the Wifi and in range of the Smart Lock.)

Yesterday my Nuki went again offline - a disaster that you guys are since month unable to fix it.
Requesting the log-file is nonsense as, first there is no information on the event in it when this is happening and secondly this is not really a log file. It’s not even possible to extract it.
Don’t get me wrong Stephan, but those proposals are since the opening of this threat the same. A smart look should 100% working and always be accessible!!
Can you pls advise when you are expecting a new firmware coming out that might have a fix? Thanks

I understand your frustration and you can be sure we want to deliver fully working products to all our customers. Things can go wrong though and our support team should always be the first contact to rule out things and check for possible issues.

Regarding your FW-questions:

Latest Bridge FW-Beta

And latest Smart Lock FW-Beta

should be base for the next public releases (depending on feedback we gather from last tests).

You can also check change logs for differences from current public versions there.

Also we got some issue with iOS App 2.2.0 and the remote state, so alos be sure to check for an update there (2.2.2 available).

Do these mentioned beta versions fix the problem? (“Improved reconnect” does not sound like the problem is found and fixed!) My NUKI always went offline after a few minutes. I already regret buying the whole package (the lock, the gateway and the keypad).

What is the result of your internal tests? Did you find the bug/the problem? When will the new stable firmware be released? Or do i have to return the whole set to amazon?

I’m really disappointed!

All those Beta versiosn fix known problems, but we keep it vague as they are still Beta and not recommended for productive use for everyone. If you check with our support ( or via phone) to verify that your personal issue is covered by those fixes they will suggest you to go for the Beta version if a quick fix is needed. Else they will ask for more details/logs to see if this is an individual problem and/or something we didn’t spot yet.

If it is not that urgent for you or you are unsure you can wait for the firmwares to soon go public in final versions.