Nuki integration in Home Assistant not working


I have a Nuki 2,0 Lock with a bridge and am trying to integrate it into Home Assistant.

Below is my config which I have put in configuration.yaml.

Nuki Lock


  • platform: nuki
    host: 192.168.xx.xx
    port: 8080
    token: xxxxxx

However Home Assistant gives no error BUT the lock device or entity is not created in HA.

Can anyone help me with this?

Does the Bridge have to be in Maintainance Mode throughout the HA reboot?

Sajive Trehan
Zurich Switzerland

Have you got this working?

My configuration.yaml does not include the port line (8080 is the default), but otherwise is much the same. Seems to work well. Is your indentation right? Hard to tell in these posts.

I have got the same Issues since the last two Firmware Updates on the Lock. Adding the Port to my config changed nothing.

The Lock is unavailable in Home Assistant. Doesn’t seem to come back. That means for me, either i will stop my automations or switch the Lock for something else.

It worked like a charm until like two weeks ago. Even in the Nuki app it is offline many times.

Home Assistant log says a lot of timeout errors like “socket.timeout: timed out”

I’m loosing the “Wife Seal of approval”

This seems to be an issue relating to recent updates of Home Assistant, rather than Nuki. There is a discussion on Github here.

1 Like

At first sight this issue seems to have been resolved by the latest Home Assistant upgrade (0.112).

… but apparently not. Discussion continues on Github.

Still not working …