Lock button not working


I’m a new Nuki user/dev and while playing with the lock to undertand API and capabilities, I realized the button on the lock is not working at all. The problem seems to be the lock won’t work unless in a specific position. The lock won’t lock from it’s ‘normal unlocked’ position, unless I manually turn it anticlockwise until the latch would start to move.

Is this a normal behaviour? Shouldn’t the button (lock, unlock, etc…) work regardless of the position? Is there anyway to solve this?


I am not 100% sure I understand your problem, but standard button behaviour should be “intellegent”, i.e. lock if unlocked and unlock/unlatch (depending on your settings) if locked before.
The button can be disabled in settings. If this strange beahaviour stays even after a reset I would recommond you contact our customer support for a check/replacement if needed.

Thanks Stephan. Since I see to be the only one experiencing this issue, it might be a hardware issue. I will exchange my Nuki and see if a new one solves the issue.


Hi Stephan,

After testing the same Nuki in a different lock, it seems to work. I think the problem is connected to the offsets after calibration. The lock seems to be in a strange state where the button won’t do anything unless I rotate manually the knob a bit (then it works). Is there any way to manually modify the calibration offset?


Yes, you can try the “Optimize locking” feature in the App with “Custom” settings where you can manually adopt the locking angles. Maybe you can find a solution for your issues with this.


I think I have a similar problem. When I press the button on the Smart Key, nothing happens. I tried different positions (manually turned the lock dial), but still doesn’t work. Any ideas?

Thank you!

Please contact our support via https://nuki.io/en/support-request/ or contact@nuki.io as this is an individual problem and might require sharing logs or direct help to solve.