Installation app Nuki won’t work, no pincode found


We purchased a Nuki smartlock 2.0 about a year ago, to install in our new home. Today we installed the smartlock on the door; so far so good. Then we got to the part of linking Nuki to the app. This process goes well, until we have to enter a pincode…

We don’t have a pincode, where can we find it? Without it we can’t even reset the lock to go through the process again. Can anybody tell me where to find the pincode?


When you set up a Lock then you enter a PIN code of your choice. This is for your safety.
Only people that have the PIN code can do the administration on your lock after the setup.

So if you set up the app for the first time, enter a 4 digit PIN and repeat this so that your Lock is not re-configurable by other people. The app on your phone will remember the PIN. So you do not need to enter the PIN each time you go into the administration menu. For normal operations (e.g. unlocking the door) the PIN is not needed.

Thanks for your reply. We tried to enter a pin of choice, but we then get the message ‘wrong pincode, try again’. After 2 or 3 tries we get blocked and need to wait. We tried different options, but it isn’t working

You can reset a Smart Lock where you have physical access to via the menu of the Nuki App:

Burger Menu => Help => Factory Reset Smart Lock

Thanks a lot! I now entered the full setup in the app (with kaibration) and the lock works :slight_smile: