IFTTT doesn't show name/date/door name, but generic info


I have IFTTT integration with Nuki so that i get a notification everytime somebody opens the door. However, the notification i get is exactly this:

{{Name}} unlocked {{Door}} at {{CreatedAt}}

However if i open IFTTT then i see the correct details, like this for instance:

April 17, 17:45
John Doe unlocked door MyGreatApartment.

It even shows correctly, in IFTTT, if the person used the Nuki Fob or just opened the door manually.

I am using Android 9, if that is of any useful information. Do you have any idea what i could do to receive also the notification correctly? I mention that i already tried deleting and re-adding the IFTTT applet.
Thank you.

If you already deleted the Applet and set it up new there is not much left to try.

Some questions which could help us investigate:

  • Do you have an Applet version ID for me? (not the general Applet ID)
  • Does it never show correctly in the notifications or only somtimes?
  • As you wrote Fobs and manual locking is shown correctly: Do you have any Names with special characters?

2 things which could be interesting to try:

  • Set up notifications without the name (only {{Door}} and {{CreatedAt}}) to compare
  • Use another action (e.g. e-mail) to check if the same problem persists there, or if only notifications are afffected

Tbh, this can be tricky. I also had this once or twice in my tests and also had a user reporting the same issue here. But I could not really reproduce it. I just want to try to rule out the possibility that we are providing data which breaks the notification in some way in your case.

Hello Stephan and thank you for your answer.

  1. Applet ID NwYHrpWq. Same thing with applet VeuK6LsN - both official applets created by Nuki as far as i can tell.
  2. It NEVER shows correctly.
  3. I don’t have any special characters in the names.
  4. I have enabled a few days ago the applet CyEnR3hk (Track who arrives home in a Google Spreadsheet), but the file is not created (it is not an issue with IFTTT -> Google authorization because i have other applets doing similar spreadsheets/docs that work just fine) . However i created manually an applet that would log the entries in a google doc and that is working fine, shows all the details correctly (although for every action it creates a new file, don’t know why).
  5. I also created several applets to send email, however that also doesn’t work.

So bottom line is that apparently only the notifications are messed up and IFTTT integration is a hit-or-miss option in certain situations.
Kind regards.

For further checks of the IFTTT logs I would need the Applet version IDs (best via PM).


As you wrote the values are shown correctly in https://ifttt.com/activity I can’t see any reason atm why they should be constantly wrong in the notifications though.

I also use our Applet templates for testing and still can’t reproduce this. But you could still try to set up a new Applet yourself where you fill in the action text manually (which would be a very strange behaviour on IFTTT side when it worked, but maybe it is worth a try).

Basic advice if nothing was working would be:

  • Please make sure your Activity log is enabled. This can be the problem if you never get correct notification.

  • If this was already enabled you could try to re-add the Smart Lock to Nuki Web (delete in Nuki Web, delete the Nuki Web User in the App, activate Nuki Web from the App again) and then reset the Service-connection to IFTTT (unfortunately all Applets will be deleted when doing this and you have to set them up again).

  • Send me your Bridge ID and firmware version in a PM if all above does not help and/or you are also experiencing general problems with gettint correct status and automatic synching in Nuki Web.

But seems that is not the case for you.

Regarding Google docs creating a new file on every action, this normally is due to some ambiguity/automatically replaced characters in the path/file-name set.
Can’t see that being a problem on our side. I map 4 different Applets to one Google doc for a complete log of my test-setup without problems.

Hello Stephan.

The IFTTT Applet ID is as i wrote in the previous message:

Activity log is enabled and working.

As you suggested I just created an applet manually that does the exact same thing and has the exact ingredients and the notification is displayed properly! Then i re-enabled the previous applet (Receive a notification when a specific person unlocks the door - by Nuki) and that creates the same error: {{Name}} unlocked {{Door}} at {{CreatedAt}}

So, the applet from the IFTTT store creates that error, the applet i made manually that is identical works fine. Beats me.

Thus, for posterity and if anyone should face this problem, try first creating an applet manually and see if works.

Thank you for your help, keep up the good work, Nuki rocks!

You have to open it up from https://ifttt.com/my_applets to see your (personal) Applet version ID (which is always numeric).

But good to hear you could solve it for you.
As this worked for you I will also try to redo the ingredients in our original Applet; maybe this solves the issue for the future!

Stephan, i saw you updated the applet, i checked it out and this new one worked perfectly!
Just make sure you withdraw the old one, that is faulty, as it still is available and also has the same name.

1 Like

Thanks for the quick feedback!

I can’t just edit published Applets (that’s why I didn’t try this earlier, as it really is a hazzle). And I also can’t delete Applets, just archive them, where they still stay visible and usable for everyone who already had it running. (Which both totally makes sense for consistency reasons). But after you delete the Applet at your account you shouldn’t be able to view or enable it again.

Strange thing is, that the new one is just a copy of the old with no settings changed … :wink:

1 Like

Stranger things have happened and probably will :slight_smile:
I deleted the old applet and indeed, i can’t find it anymore if i search for it. So you are future-proof.
For now :crazy_face:
Have a nice weekend.

1 Like