Homekit showing wrong status

Is this “wrong status” in homekit app definitively fixed?

No. Sometime after the 2.4.1 firmware the problem appeared again. Now i still get the Unlocking status randomly when the door is closed. The notifications although are correct

1 Like

Same here with latest beta firmware. If I lock or unlock from the home app it updates correctly, but if I unlock or lock it from the Nuki app (or manually) it stays in “unlocking” (if I lock it) or “locking” (if I unlock it) status. I’ve written correctly, the status is the opposite of the action taken, like the accessory don’t receive the update. Manually clicking on the accessory report it back to the correct status.

Hope I’m clear to explain this…


1 Like

Same issue here. However, if I click the “stick” icon in HomeKit the lock actually locks again/further. I have nuki set to only lock 360 degrees, so it then locks to 720 (“confirmed” as a subsequent unlock takes quite longer as usual).

1 Like

okay, great I was looking for changing my actual lock (Danalock V3 homekit) but as I can see issues are the same…

I just moved from the Danalock V3 HK.

Never really experienced this issue on Danalock,

But I can tell you the features Nuki offers are leaps and bounds ahead of Danalock.

I’m currently at work and this is what the Home App on both my iPhone and my MacBook is showing me:

It is stuck in this “Unlocking…” state. The app shows me that the door is closed and locked. I hope so, but I’m not sure whom to trust here…

This is really unacceptable, and I’m shocked it’s been a known issue for so long.
Imagine if I was out of town, this is really unsettling.

App Version: 2.4.0
Nuki Lock Version: 2.5.4

This is still not fixed.
I’ve got only smart lock 2.0 (no bridge) with firmware 2.7.20 and apple tv as hub and two iPhones.
In home app (MacBook, iPhone) I often see “unlocking…” state. Siri frequently says “I have no answer from your lock…” (or something similar) when I ask to open or close the door, etc.

I have 2 problems.

Sometimes I have that the lock indicates that it is stuck.
While it has just been locked and has no problems, the Nuki app indicates that it is locked.
What can I do about it?

Another problem I have is that when I ask Siri to open the door I get there is no response from the lock and I have to do it again.
The lock did open.
or that I get back lock is still unlocking ask in a few minutes if it succeeded.
WHY is this still a problem and how can I fix it? firmware is 2.8.15

I’m considering buy Nuki.
In home app I get information if door is open or only if it is locked / unlocked?

Only locked, unlocked and battery state. Apple/HomeKit does currently not support door locks with integrated door sensors.

Sorry but I have a Shelly 1 with firmware for HomeKit and a sensor connected and HomeKit recognizes when it is opened or closed and displays this info within the tile and in status bar.

Shelly does not have official HomeKit support, so whatever they are doing is similar to what you can do with Homebridge and a Nuki lock. Lots of this things are officially not supported by Apple. In the case you mentioned (i guess) shelly exposes itself as “door”. Nuki is a lock and classified and certified from Apple as such.

I am suffering from this issue in the last weeks.

I’m on software 2.10.8 (installed on the 6th of March 2021) and auto updates are on. I have a nuki bridge and a Homepod Mini as Homekit concentrator. My app is on 2.7.7 and my phone is running latest iOS 14.4.1

I usually use the physical double click on the lock to open and lock the door behind me.

To be honest, I consider this bug as VERY worrying. I’m myself now used to it, so I double check on the Nuki App. But someone could beleive the door is not locked and click on the lock icon on homekit to lock the door, which I suspect would in reality unlock the door! And if he happens to have a door like mine, which would slighlty open when fully unlocked, there would be no possibility to lock it again remotely…

I have a suspicion I have this issue since I installed the bridge
I had the bridge since day 1 but I noticed long after in the nuki app (which I rarely check, as using homekit mainly) that the lock wasn’t connected to the bridge. I then reinstalled it and the bridge is working.