Homekit showing wrong status

Same here, can’t really lock/unlock from HomeKit, it’s stays in locking… or unlocking… until it shows the accessory as Not responding. Through the nuki app everything good

I didn’t find any solution so now I’m using Homebridge Nuki plugin any everything works fine (except little delay when performing any actions). But you will need Nuki bridge. I hope Nuki team or Apple (I don’t know who’s fault it is) will fix this soon.

Please make sure that your Smart Locks are part of the beta program (https://developer.nuki.io/c/beta-program). There will be a new firmware within the next few days, which we’d like you to test.

There is now a new Beta firmware 2.4.1 available, with some changes in how the HomeKit status is reported to Apple devices. Please give it a try and let us know if the problems you reported still persist for you.

Has anyone tested this with the 2.4.1 Beta?

Nope.
Sent an email to enable my account for the hardware beta program but still waiting for a response.

We just rechecked and your SL (with the ID you sent us on 3rd of Feb) is already in the Beta group.
Please check for an update in the App manually (Manage Smart Lock > Firmware update).

Thank you, Stephan! Seems I was waiting for a trigger to inform me that I am now part of the hardware beta as well. Do you usually send a feedback for such emails? Couldn’t find any here.

@Jürgen, I just tried the new firmware and the Homekit behaviour is now exactly what I was expecting: A device, dedicated for lock status. Do you plan to add another device to represent the door opening status?

Regards,
Julian

Forgot to mention: It took like 20 seconds after unlocking the door for the Homekit device to change status from “unlocking …” back to the static “unlocked” message. Guess that’s to be expected when BTLE is involved so everything should be fine here as well.

@Door status in HomeKit: I can confirm that we want to have this in HomeKit on the long run. However there’s not ETA for this.

@Up to 20s: Yes, this is “normal” because the bridge and HomeKit are “battling” for access to the Smart Locks single BLE connection after a state change. If HomeKit wins you get the notification ~3-5s after the lock state change happened. If the bridge wins it takes up to ~20s.

1 Like

i tested with 2.4.1 and it seems problem solved

1 Like

I wanted to share something I observed:
It seems that sometimes a NUKI Key will not work immediately and one needs to press the button multiple times. While I can understand the reason behind might be similar to what Jürgen explained to us above, this is something I didn’t see with the old firmware.
Might be my 2 month old NUKI Key is breaking already (as one can read quite a lot of stories about the product quality), but that’s a different story :wink: I’d rather say it is software at the moment, not about the hardware.

If I understand you correctly you mean the Nuki Fob seems to be working more unreliable with the new Smart Lock firmware?

Yes indeed, it is about the Fob, sorry… :grimacing:

Is this “wrong status” in homekit app definitively fixed?

No. Sometime after the 2.4.1 firmware the problem appeared again. Now i still get the Unlocking status randomly when the door is closed. The notifications although are correct

1 Like

Same here with latest beta firmware. If I lock or unlock from the home app it updates correctly, but if I unlock or lock it from the Nuki app (or manually) it stays in “unlocking” (if I lock it) or “locking” (if I unlock it) status. I’ve written correctly, the status is the opposite of the action taken, like the accessory don’t receive the update. Manually clicking on the accessory report it back to the correct status.

Hope I’m clear to explain this…

Regards

1 Like

Same issue here. However, if I click the “stick” icon in HomeKit the lock actually locks again/further. I have nuki set to only lock 360 degrees, so it then locks to 720 (“confirmed” as a subsequent unlock takes quite longer as usual).

1 Like

okay, great I was looking for changing my actual lock (Danalock V3 homekit) but as I can see issues are the same…

I just moved from the Danalock V3 HK.

Never really experienced this issue on Danalock,

But I can tell you the features Nuki offers are leaps and bounds ahead of Danalock.