Firmware update 2.5.4 stack at installing


I tried installing version 2.5.4 on my Nuki smart lock 2.0 3 times today, left it more than 1 hour and it froze at the installing phase. I had to remove the batteries to make the lock operational again.

Any suggestions?


Here the same :frowning:

1 Like

same issue here…

Same issue. First try, smart lock got stuck in the process. Had to remove batteries and the second attempt was sucessfull.

Martin please how long did the update installing take. I tried it three times with no success. After a hour I disabled app and restarted nuki by removing batteries.

Hoy he actualizado el firmware 2.5.4 en mi primera smartlock a funcionado perfectamente y a la primera tiempo total 3 minutos, eso sí con la actualización de la app de nuki, ahora a probarla, debo decir que tengo 4 smartlock con sus respectivos brigde y he notado una gran mejora desde que hace 3 meses compré mi primera nuki, sencillamente me encanta.

I 've just sucessfully updated my firmware.
Here are steps that seems to helped me to fix a update issue.

  1. restart nuki by removing batteries from nuki
  2. I swiped off all running apps on my phone
  3. restart a phone
  4. again restart nuki by removing batteries
    (after this I changed wifi from 5ghz ap to 2.4ghz ap on my phone but i dont think that this could be related to successfully update)
  5. I tried firmware update again. Now succesfully

I hope that it will help you. Firmware update took only about a few minutes.

Hi @all,

Can you please share the app (android or iOS) you’re using and which app version?
Also which firmware version is currently installed on the smart lock.


Used App Version 2.3.0 on Android. Updated from firmware 2.4.x (sorry - can’t remeber exactly and only took a short glimpse on the firmware info before updating. ;-). Now it’s on 2.5.4.

Android 9.0
nuki app - 2.3.0
firmware before: 2.4.5? (I guess, last stable release)
firmware now: 2.5.4

I can provide debug log from my app from firmwares unsuccessful update tries

Hi everybody!
After trying one unsuccesful trial (waiting for more than one hour), I just

  1. removed the batteries from the nuki smart lock
  2. closed all the open apps in my phone
  3. opened again the nuki app
  4. tried again the instalation

Now succesfully!

No more than 5 minutes for the installation.
Good luck!

1 Like

Tried again after removing batteries. Now successful.

1 Like


i can’t update firmware from 2.5.2 to 2.5.4. I have two iphone and i tried several time. i removed battery and retry, again and again… without succesful. I don’t understand why it is so difficult to install a firmware. I notice I’m not the only one with this problem

1 Like

Hallo zusammen, auch ich hatte erst Probleme die Software Version 2.5.4 zu installieren und es erst nach dem Dritten Anlauf mit einem Reset auf Werkseinstellung hin bekommen. Seit dem macht das System nur noch Probleme im Betrieb. Die vorherige Software Version lief stabil und ohne Probleme. Das Problem ist bei Nuki bekannt und man arbeitet wohl an einer Lösung. Nichts gegen die österreichische Gelassenheit die ich sehr Schätze aber die Kunden hier so lange hängen zu lassen und keine fehlerbereinigtes Update zur Verfügung zu stellen ist sehr enttäuschend. Warum wird nicht die letzte Version unter einen neuen Nummer bereit gestellt? Wann ist mit einem Fehlerupdate zu rechnen. Zur Zeit macht das Smart Lock was es will.

Please contact customer support: or