Cannot upgrade nuki smart lock 2.5.4 to 2.6.4

Hi everyone, I recently bought my nuki set (lock, bridge, keypad and opener) with plans to install in an airbnb apartment after testing it for some time at home and being sure how it works.

I installed smart lock, bridge and opener a week ago and after initial setup I’m facing some issues since first day that am not able to resolve myself or find similar issues here. I contacted support via mobile app, send all the details but haven’t received any response apart from the automatic mail :frowning:

Smart lock issues:

  • cannot upgrade its version (running 2.5.4, something that I don’t understand 100% why it wasn’t delivered with latest stable): when I run the upgrade it uploads to the device and ask to press the smart lock button, nothing happens the device doesn’t enter in maintenance mode but goes to position detection (read Can't update firmware - can't get into Maintenance mode which seems very similar but tried all commented in there without success)

  • the smart lock button actions are not working: regardless any configuration change I perform, the button is not working at all.
    I wonder if this second issue is related to the previous one and maybe the button of my device is not working fine.


  • notifications are not sent to mobile whenever anyone rings the building door, which makes it a bit useless unless I activate the continue mode I’m afraid. Continue mode is not an option always due to security reasons


  • I need to enter the code twice because first time never works, it simply does nothing


support team finally contacted and I managed to resolve it so though on sharing solution in case others face similar problem.
I think most of the issues were related to a first failed upgrade of firmware of smart lock that was causing: cannot enter in maintenance mode so no way to reset to factory settings, retry the upgrade, …

The key is to restart the smart lock by removing the batteries, I was doing it but putting them back almost immediately (2-3 seconds…) but it is needed to leave them out for longer. After that I could upgrade firmware and button actions started working, also the keypad is working ok.

Only issue I don’t see relation is the opener notifications but somehow are now working, probably I reconfigured twice and started working.


1 Like