Any way to update the lock state faster in home Assistant?

The lock state does not update fast enough in home Assistant integration when I unlock and lock the door in sequence for example, are there aren’t configurations to improve this?

With the official Nuki integration, the update happens via polling.
So I guess no way to improve the speed.

For that reason I switched to GitHub - kvj/hass_nuki_ng: Better support for Nuki devices in the Home Assistant
With that integration, the update happens almost instantaneously.
I’ve been using it for over a year now and it works very well.

Yet another option would be to go with GitHub - technyon/nuki_hub: Use an ESP32 as a Hub between a NUKI Lock and your smarthome.
where you even no longer need a nuki bridge.

That one I haven’t tried yet, but I already have the ESP32 on my desk, so one day when I am bored … :slight_smile:


Its response were fast when I first installed but now when I unlock the door it takes sort of 12 seconds to update the state to open in HA :confused: does it also happens to you?

No, nuki_ng is almost instantaneously for me - max delay maybe 1 sec.

  • Check your brigde settings (see pic below)
  • make sure you have good wifi rssi values (I had some problems when the values went below 75) , so I relocated the bridge.
  • maybe a reboot of the bridge can help

Cool, I’ll check that, thank you

It looks like perfect right? Or am I misreading the data? It takes 10-12 seconds to update in home Assistant… no clue why (I already rebooted

The issue does not happen if I control the lock via home assistant, but if I lock or unlock manually/keypad/Homekit it takes veeery long to update the state