Android App - Auto. Unlock performed uncontrollable

Hi Everyone!

I have a problem with the auto. unlock feature with my Nuki SmartLock 3.0 Pro + Android App (version 2022.3.1) on my Samsung Galaxy S20:
Since the android app update to the version before 2022.3.1 (I can’t remember the version number), my smart lock unlocks the door RANDOMLY! No matter if I am inside the geofence or outside, the lock sometimes unlocks my door. This is a BIG SECURITY ISSUE. I can’t even see a log message in the protocol. I also managed to activate the debug mode to see additional log messages in the protocol, but also with the debug mode activated, I can’t see further log messages (Basically I can’t see any debug messages at all).

A temporary fix for me is to disable the auto. unlock function on my android smartphone. But certainly I want to use the auto. unlock feature (it already worked well before the android app update). Please fix this issue, because in my opinion it’s a big security issue if the door get’s unlocked, without any reason (even no logs are provided in the protocol).


Please contact our support via the Nuki App (Menu > Help > Contact Customer Support) as this is an individual problem and might require sharing logs and other sensitive data.

Hi Jürgen!

Thank you, I will contact your support.

I had the same issue with my samsung S10 and I was able to determine that my samsung had an issue with GPS. Sometimes my GPS wasn’t functioning correctly. After updating my phone to the latest Samsung OS update, the GPS is functioning correctly again and haven’t had any issues since.

I have had this issue while being near the lock due to the location data from my device being inaccurate. (Google Maps will show me hundreds of metres away from it at times). Changing the geofence radius to the largest value (1000m) has mostly quelled it, but there was a point in time where the non-GPS geolocation would place me even further than that, and the flip flopping between that wrong location data and the correct one caused me to “exit” and then “re-enter” the geofence, and cause an Auto-Unlock, multiple times per day. The only way to fix that was to report the incorrect location to Google. (In Google maps, wait for the location to be wrong, then send a Feedback report of the blue dot being in the wrong place.)

Hi! Have you tried to just use Bluetooth For Autounlock/lock and disable Geofence!? I think this is a downside of the Bridge built in inside the lock (Version 3) now, because I have read this issue very often now and just with Version 3 of the locks, - myself I have two locks (Version 1&2) and a separate Bridge, and never had such issues myself, and never heard from such issues from others, just with Version 3 of the locks this was starting to come up, I think!?

This can not be the case because the bridge is not involved into Auto-Unlock at all. Therefore it does not matter if there is one or not or if the Smart Lock has WiFi directly built into it.

I understand, thanks for the clarification.